summaryrefslogtreecommitdiffhomepage
path: root/contrib/package/remote-update/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-07-07 03:59:49 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-07-07 03:59:49 +0000
commit96a8d3d0d81f00252345328432bc65c26c8ae0d2 (patch)
tree7ca597e4800df7bdf7955c43c96117897e47232d /contrib/package/remote-update/Makefile
parent601c020b4eda3b9848ae03f8380588e82c053758 (diff)
contrib/package: move remote-update to own package
Diffstat (limited to 'contrib/package/remote-update/Makefile')
-rw-r--r--contrib/package/remote-update/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/contrib/package/remote-update/Makefile b/contrib/package/remote-update/Makefile
new file mode 100644
index 000000000..c8adceeaa
--- /dev/null
+++ b/contrib/package/remote-update/Makefile
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2009 Jo-Philipp Wich <xm@subsignal.org>
+#
+# This is free software, licensed under the Apache 2.0 license.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=remote-update
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/remote-update
+ SECTION:=luci
+ CATEGORY:=LuCI
+ SUBMENU:=Freifunk
+ TITLE:=Freifunk remote update utility.
+ DEPENDS:=@TARGET_atheros||@TARGET_ar71xx||@TARGET_brcm-2.4
+endef
+
+define Package/remote-update/description
+ The freifunk remote-update utility uses sysupgrade to reflash the currently
+ running firmware while keeping most of the existing configuratio.
+endef
+
+define Build/Prepare
+ mkdir -p $(PKG_BUILD_DIR)
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+endef
+
+define Package/remote-update/install
+ $(CP) ./files/* $(1)/
+endef
+
+$(eval $(call BuildPackage,remote-update))