summaryrefslogtreecommitdiffhomepage
path: root/contrib/package/px5g/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-03-22 21:27:00 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-03-22 21:27:00 +0000
commitbc7bf3a857636b46c76b39d2c0322fa43f295bbb (patch)
treea770023dafd2f47597c10c7044248d97264d28e8 /contrib/package/px5g/Makefile
parentd817ebf0070cd6c70b49fb3c4e13becb0544e429 (diff)
contrib/package: backport px5g from luci2
Diffstat (limited to 'contrib/package/px5g/Makefile')
-rw-r--r--contrib/package/px5g/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/contrib/package/px5g/Makefile b/contrib/package/px5g/Makefile
new file mode 100644
index 0000000000..638f8c0c4e
--- /dev/null
+++ b/contrib/package/px5g/Makefile
@@ -0,0 +1,39 @@
+#
+# Copyright (C) 2010 Jo-Philipp Wich <xm@subsignal.org>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=px5g
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/px5g
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=Standalone X.509 certificate generator
+endef
+
+define Package/px5g/description
+ Px5g is a tiny standalone X.509 certificate generator.
+ It suitable to create key files and certificates in DER
+ and PEM format for use with stunnel, uhttpd and others.
+endef
+
+define Build/Prepare
+ mkdir -p $(PKG_BUILD_DIR)
+ $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
+define Package/px5g/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/px5g $(1)/usr/sbin/px5g
+endef
+
+$(eval $(call BuildPackage,px5g))