summaryrefslogtreecommitdiffhomepage
path: root/contrib/package/olsrd-luci/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-03-25 12:53:08 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-03-25 12:53:08 +0000
commitd674c54faca07cf84ecd45458028c1364b58e448 (patch)
tree074a8bf31b60e85ef53dd47e21f926d64e701351 /contrib/package/olsrd-luci/Makefile
parent303b7fccaca4177e570ae3c7038ba8d1b36d6c8c (diff)
contrib/package/olsrd-luci: add mdns plugin
Diffstat (limited to 'contrib/package/olsrd-luci/Makefile')
-rw-r--r--contrib/package/olsrd-luci/Makefile15
1 files changed, 14 insertions, 1 deletions
diff --git a/contrib/package/olsrd-luci/Makefile b/contrib/package/olsrd-luci/Makefile
index 1fc21cdf31..56dc833d79 100644
--- a/contrib/package/olsrd-luci/Makefile
+++ b/contrib/package/olsrd-luci/Makefile
@@ -126,6 +126,13 @@ define Package/olsrd-luci-mod-watchdog
DEPENDS:=olsrd-luci
endef
+define Package/olsrd-luci-mod-mdns
+ $(call Package/olsrd-luci/common_info)
+ MENU:=1
+ TITLE:=OLSR - mDNS Plugin
+ DEPENDS:=olsrd-luci
+endef
+
TARGET_CFLAGS += $(FPIC)
define Build/Compile
@@ -141,7 +148,7 @@ define Build/Compile
MANDIR="$(PKG_INSTALL_DIR)/usr/share/man" \
STRIP="true" \
INSTALL_LIB="true" \
- SUBDIRS="arprefresh bmf dot_draw dyn_gw dyn_gw_plain httpinfo nameservice secure txtinfo quagga watchdog"
+ SUBDIRS="arprefresh bmf dot_draw dyn_gw dyn_gw_plain httpinfo nameservice secure txtinfo quagga watchdog mdns"
endef
define Package/olsrd-luci/install
@@ -208,6 +215,11 @@ define Package/olsrd-luci-mod-watchdog/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/watchdog/olsrd_watchdog.so.* $(1)/usr/lib/
endef
+define Package/olsrd-luci-mod-mdns/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/mdns/olsrd_mdns.so.* $(1)/usr/lib/
+endef
+
$(eval $(call BuildPackage,olsrd-luci))
$(eval $(call BuildPackage,olsrd-luci-mod-arprefresh))
@@ -221,3 +233,4 @@ $(eval $(call BuildPackage,olsrd-luci-mod-secure))
$(eval $(call BuildPackage,olsrd-luci-mod-txtinfo))
$(eval $(call BuildPackage,olsrd-luci-mod-quagga))
$(eval $(call BuildPackage,olsrd-luci-mod-watchdog))
+$(eval $(call BuildPackage,olsrd-luci-mod-mdns))