summaryrefslogtreecommitdiffhomepage
path: root/contrib/package/meshwizard
diff options
context:
space:
mode:
authorManuel Munz <freifunk@somakoma.de>2013-01-29 22:32:03 +0000
committerManuel Munz <freifunk@somakoma.de>2013-01-29 22:32:03 +0000
commit13a7013acd78c41200e127c9e7558c17ce135d79 (patch)
tree57165868ac4c5b28f44e9dbfc764c0aaf4c526fa /contrib/package/meshwizard
parent9846cfc0938aeaa91270f72fdeaac0a41892903e (diff)
contrib/meshwizard: Use the new interfaces syntax instead of the old alias syntax for dhcp interfaces
Diffstat (limited to 'contrib/package/meshwizard')
-rw-r--r--contrib/package/meshwizard/Makefile2
-rwxr-xr-xcontrib/package/meshwizard/files/usr/bin/meshwizard/helpers/setup_network.sh9
2 files changed, 5 insertions, 6 deletions
diff --git a/contrib/package/meshwizard/Makefile b/contrib/package/meshwizard/Makefile
index 3aaddec25..91979b74e 100644
--- a/contrib/package/meshwizard/Makefile
+++ b/contrib/package/meshwizard/Makefile
@@ -4,7 +4,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=meshwizard
-PKG_RELEASE:=0.0.8-3
+PKG_RELEASE:=0.0.9-1
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
diff --git a/contrib/package/meshwizard/files/usr/bin/meshwizard/helpers/setup_network.sh b/contrib/package/meshwizard/files/usr/bin/meshwizard/helpers/setup_network.sh
index 325475fa6..70f82fe2a 100755
--- a/contrib/package/meshwizard/files/usr/bin/meshwizard/helpers/setup_network.sh
+++ b/contrib/package/meshwizard/files/usr/bin/meshwizard/helpers/setup_network.sh
@@ -58,7 +58,7 @@ if [ "$net_dhcp" == 1 ]; then
fi
}
config_load network
- config_foreach handle_dhcpalias alias
+ config_foreach handle_dhcpalias interface
# Get IP/netmask and start-ip for $net dhcp
# If no dhcprange is given in /etc/config/meshwizard we autogenerate one
@@ -69,15 +69,15 @@ if [ "$net_dhcp" == 1 ]; then
fi
eval $(sh $dir/helpers/ipcalc-cidr.sh $dhcprange 1 0)
- # setup wifi-dhcp interface or alias
+ # setup wifi-dhcp interface or alias (using interface notation)
# Setup alias for $net
if [ "$vap" == 1 ]; then
uci set network.${netrenamed}dhcp=interface
else
- uci set network.${netrenamed}dhcp=alias
- uci set network.${netrenamed}dhcp.interface="$netrenamed"
+ uci set network.${netrenamed}dhcp=interface
+ uci set network.${netrenamed}dhcp.ifname="@${netrenamed}"
fi
uci batch <<- EOF
@@ -86,5 +86,4 @@ if [ "$net_dhcp" == 1 ]; then
set network.${netrenamed}dhcp.netmask="$NETMASK"
EOF
uci_commitverbose "Setup interface for ${netrenamed}dhcp" network
-
fi