summaryrefslogtreecommitdiffhomepage
path: root/contrib/package/luci-splash/Makefile
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-04-26 17:14:22 +0000
committerSteven Barth <steven@midlink.org>2008-04-26 17:14:22 +0000
commit22b1721823d705c7318d1eebafdfcdaead3025da (patch)
tree1b972c0c6cd63d09975f42cca36e7ad1abd11033 /contrib/package/luci-splash/Makefile
parent224c2566416e84b7c359a31ead46ece00c120b9c (diff)
* Added experimental version of DHCP-Splash for Kamikaze
* Added MAC-Address matching to luci_fw * Added interface alias hack for Kamikaze * ffluci.sys: Added several networking helper functions * ffluci.http: Added function remote_addr * Updated Haserl to 0.9.24
Diffstat (limited to 'contrib/package/luci-splash/Makefile')
-rw-r--r--contrib/package/luci-splash/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/contrib/package/luci-splash/Makefile b/contrib/package/luci-splash/Makefile
new file mode 100644
index 0000000000..e1e194cbd5
--- /dev/null
+++ b/contrib/package/luci-splash/Makefile
@@ -0,0 +1,36 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=luci-splash
+PKG_VERSION:=0.1
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/luci-splash
+ SECTION:=admin
+ CATEGORY:=Administration
+ SUBMENU:=ffluci
+ DEPENDS:=+ffluci
+ TITLE:=FFLuCI DHCP-Splash
+endef
+
+define Package/luci-splash/install
+ $(INSTALL_DIR) $(1)/usr/lib/luci_splash/htdocs
+ $(INSTALL_DIR) $(1)/etc/config
+ $(INSTALL_DIR) $(1)/etc/init.d
+
+ $(CP) -a ./src/luci_splash/* $(1)/usr/lib/luci_splash/ -R
+ $(INSTALL_BIN) ./src/luci_splash/sync.lua $(1)/usr/lib/luci_splash
+ $(INSTALL_BIN) ./src/luci_splash/htdocs/cgi-bin/index.cgi $(1)/usr/lib/luci_splash/htdocs/cgi-bin
+
+ $(CP) -a ./src/luci_splash.init $(1)/etc/init.d/luci_splash
+ $(CP) -a ./src/luci_splash.uci $(1)/etc/config/luci_splash
+ $(CP) -a ./src/luci_splash_httpd.conf $(1)/etc/
+
+ $(CP) -a ./ipkg/conffiles $(1)/CONTROL/conffiles
+endef
+
+$(eval $(call BuildPackage,luci-splash))