summaryrefslogtreecommitdiffhomepage
path: root/contrib/package/luci-addons/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-06-11 13:29:05 +0000
committerJo-Philipp Wich <jow@openwrt.org>2014-06-11 13:29:05 +0000
commit7043c30e0e55bbbfacdddf97619b6bae96d20ddb (patch)
treeece3254350b3ba01ba3135caed2364cc7ca7804c /contrib/package/luci-addons/Makefile
parentbbb44cf245c11bc0c1d59e836007c9e8c3bfa209 (diff)
build: introduce luci-base
Merges libs/core, libs/ipkg, libs/web, libs/sys, libs/sgi-cgi, libs/sgi-uhttpd, modules/admin-core, themes/base and protcols/core into modules/base and renames luci-lib-core to luci-base.
Diffstat (limited to 'contrib/package/luci-addons/Makefile')
-rw-r--r--contrib/package/luci-addons/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/contrib/package/luci-addons/Makefile b/contrib/package/luci-addons/Makefile
index c223054a2..6a51a6adf 100644
--- a/contrib/package/luci-addons/Makefile
+++ b/contrib/package/luci-addons/Makefile
@@ -49,7 +49,7 @@ define Package/luci-mod-freifunk-community
TITLE:=Freifunk Community Meta-Package
DEPENDS+=$(call add_deps,mod-freifunk-community, \
iptables-mod-nat-extra iptables-mod-ipopt \
- luci-lib-web luci-app-splash luci-i18n-german \
+ luci-app-splash luci-i18n-german \
olsrd olsrd-mod-dyn-gw-plain \
olsrd-mod-jsoninfo olsrd-mod-nameservice \
olsrd-mod-watchdog kmod-tun \
@@ -224,8 +224,7 @@ define theme
SUBMENU:=4. Themes
TITLE:=$(if $(2),$(2),LuCI $(1) theme)
MAINTAINER:=$(if $(3),$(3),LuCI Development Team <luci@lists.subsignal.org>)
- DEPENDS:=$(if $(filter-out base,$(1)),+luci-theme-base) $(4)
- $(if $(5),DEFAULT:=PACKAGE_luci-lib-core)
+ DEPENDS:=+luci-base $(4)
endef
define Package/luci-theme-$(1)/install