summaryrefslogtreecommitdiffhomepage
path: root/contrib/package/haserl-lua
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-03-31 19:40:31 +0000
committerSteven Barth <steven@midlink.org>2008-03-31 19:40:31 +0000
commit746fdf6b472e72cb01b0c3510cc3eb04be1237b7 (patch)
treedcf3368b195b96e358824c5e5151c72d655585b5 /contrib/package/haserl-lua
parent8e49fa9c732ebc46287d6b6371d7685585b6bf02 (diff)
* Fixed a conflict with haserl 0.9.23 (FFLuCI) and haserl 0.8.x (OpenWRT)
- Thanks to mickey (FF Hannover) for this patch
Diffstat (limited to 'contrib/package/haserl-lua')
-rw-r--r--contrib/package/haserl-lua/Makefile39
-rw-r--r--contrib/package/haserl-lua/patches/100-cookie_prefix.patch29
2 files changed, 68 insertions, 0 deletions
diff --git a/contrib/package/haserl-lua/Makefile b/contrib/package/haserl-lua/Makefile
new file mode 100644
index 000000000..b2146334c
--- /dev/null
+++ b/contrib/package/haserl-lua/Makefile
@@ -0,0 +1,39 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: Makefile 1719 2008-03-24 16:07:38Z Cyrus $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=haserl-lua
+PKG_VERSION:=0.9.23
+PKG_RELEASE:=1
+
+PKG_SOURCE:=haserl-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/haserl
+PKG_MD5SUM:=31d1f505afe3ba1b351e18612aa57a70
+
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/haserl-lua
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=A CGI wrapper to embed shell scripts in HTML documents
+ URL:=http://haserl.sourceforge.net/
+ DEPENDS:=+liblua
+endef
+
+CONFIGURE_ARGS += \
+ --with-lua
+
+define Package/haserl-lua/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(STRIP) $(PKG_BUILD_DIR)/src/haserl
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/haserl $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,haserl-lua))
diff --git a/contrib/package/haserl-lua/patches/100-cookie_prefix.patch b/contrib/package/haserl-lua/patches/100-cookie_prefix.patch
new file mode 100644
index 000000000..0547d9d87
--- /dev/null
+++ b/contrib/package/haserl-lua/patches/100-cookie_prefix.patch
@@ -0,0 +1,29 @@
+--- haserl-0.9.23.orig/src/haserl.c 2008-03-18 18:17:55.000000000 +0100
++++ haserl-0.9.23/src/haserl.c 2008-03-27 16:58:27.000000000 +0100
+@@ -340,7 +340,7 @@
+ {
+ token++;
+ }
+- myputenv (env, token, global.var_prefix);
++ myputenv (env, token, global.cookie_prefix);
+ token = strtok (NULL, ";");
+ }
+ free (qs);
+@@ -614,6 +614,7 @@
+ global.acceptall = FALSE; /* don't allow POST data for GET method */
+ global.uploadlist = NULL; /* we don't have any uploaded files */
+ global.var_prefix = HASERL_VAR_PREFIX;
++ global.cookie_prefix = "COOKIE_";
+ global.nul_prefix = "";
+
+ }
+--- haserl-0.9.23.orig/src/haserl.h 2008-01-25 22:11:38.000000000 +0100
++++ haserl-0.9.23/src/haserl.h 2008-03-27 16:58:18.000000000 +0100
+@@ -10,6 +10,7 @@
+ char *uploaddir; /* where we upload to */
+ char *uploadhandler; /* a handler for uploads */
+ char *var_prefix; /* what name we give to FORM variables */
++ char *cookie_prefix;
+ char *nul_prefix; /* what name we give to environment variables */
+ token_t *uploadlist; /* a linked list of pathspecs */
+ int debug; /* true if in "debug" mode */