summaryrefslogtreecommitdiffhomepage
path: root/contrib/package/haserl-lua
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-04-05 15:12:02 +0000
committerSteven Barth <steven@midlink.org>2008-04-05 15:12:02 +0000
commit6adf7451cff19b48dd75762e9242becb8a51e247 (patch)
treea3f82935db2ce9ef68bc59fa1d973d8b2c33e167 /contrib/package/haserl-lua
parent55c2ac261f7bc865cf7fc2abe6c69ffd87a098ac (diff)
* Added own custom version of Lua
* Updated Lua to produce architecture-independent bytecode * Updated Lua to load bytecode from different endianess * Updated Lua to use optimized integer arithmetic for CPUs without an FPU * Updated haserl-lua to fit to optimized Lua version (hopefully this should fix: "bad header in precompiled chunk" on some platforms) * Luci core will now be bytecompiled and stripped by default to save disk space and CPU time
Diffstat (limited to 'contrib/package/haserl-lua')
-rw-r--r--contrib/package/haserl-lua/Makefile2
-rw-r--r--contrib/package/haserl-lua/patches/200-bytecode-header-luci12
2 files changed, 13 insertions, 1 deletions
diff --git a/contrib/package/haserl-lua/Makefile b/contrib/package/haserl-lua/Makefile
index c531d3399a..9b5b198fc1 100644
--- a/contrib/package/haserl-lua/Makefile
+++ b/contrib/package/haserl-lua/Makefile
@@ -24,7 +24,7 @@ define Package/haserl-lua
CATEGORY:=Utilities
TITLE:=A CGI wrapper to embed shell scripts in HTML documents
URL:=http://haserl.sourceforge.net/
- DEPENDS:=+liblua
+ DEPENDS:=+liblua-luci
endef
CONFIGURE_ARGS += \
diff --git a/contrib/package/haserl-lua/patches/200-bytecode-header-luci b/contrib/package/haserl-lua/patches/200-bytecode-header-luci
new file mode 100644
index 0000000000..c93fe7ae66
--- /dev/null
+++ b/contrib/package/haserl-lua/patches/200-bytecode-header-luci
@@ -0,0 +1,12 @@
+diff -ur haserl-0.9.23.orig/src/haserl_lualib.inc haserl-0.9.23/src/haserl_lualib.inc
+--- haserl-0.9.23.orig/src/haserl_lualib.inc 2008-04-05 16:40:35.000000000 +0200
++++ haserl-0.9.23/src/haserl_lualib.inc 2008-04-05 16:41:37.000000000 +0200
+@@ -1,7 +1,7 @@
+ /* This file was automatically generated from haserl_lualib.lua. DO NOT EDIT */
+
+ static const unsigned char haserl_lualib[] = {
+- 27, 76,117, 97, 81, 0, 1, 4, 4, 4, 8, 0, 19, 0, 0, 0,
++ 27, 76,117, 97, 81, 0, 1, 4, 4, 4, 8, 4, 19, 0, 0, 0,
+ 64,104, 97,115,101,114,108, 95,108,117, 97,108,105, 98, 46,108,
+ 117, 97, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 2, 3, 16,
+ 0, 0, 0, 10, 0, 0, 0, 74, 0, 0, 0,138, 0, 0, 0,135,