summaryrefslogtreecommitdiffhomepage
path: root/contrib/package/haserl-lua/Makefile
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-04-27 11:10:09 +0000
committerSteven Barth <steven@midlink.org>2008-04-27 11:10:09 +0000
commite895253a9b6b165f94af3480de59020617b7117c (patch)
treedd2438003c28a2b63b1e07d0e6781aac69bc3c03 /contrib/package/haserl-lua/Makefile
parentace012a0325a4ad2249b137a0d7c7edcc2a71f54 (diff)
* Fixed broken commit
Diffstat (limited to 'contrib/package/haserl-lua/Makefile')
-rw-r--r--contrib/package/haserl-lua/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/contrib/package/haserl-lua/Makefile b/contrib/package/haserl-lua/Makefile
new file mode 100644
index 0000000000..ed4279bfdd
--- /dev/null
+++ b/contrib/package/haserl-lua/Makefile
@@ -0,0 +1,40 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=haserl-lua
+PKG_VERSION:=0.9.24
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://dev.leipzig.freifunk.net/svn/ff-luci/trunk/contrib/package-source/ \
+ http://firmware.freifunk-halle.net/ffluci/package-source/
+PKG_MD5SUM:=b004005594b84e35839b1d5c330f8e03
+
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/haserl-lua
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=A CGI wrapper to embed shell scripts in HTML documents
+ URL:=http://haserl.sourceforge.net/
+ DEPENDS:=+liblua-luci
+endef
+
+CONFIGURE_ARGS += \
+ --with-lua
+
+define Package/haserl-lua/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(STRIP) $(PKG_BUILD_DIR)/src/haserl
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/haserl $(1)/usr/bin/
+ echo "Replaces: haserl" >> $(1)/CONTROL/control
+ echo "Conflicts: haserl" >> $(1)/CONTROL/control
+endef
+
+$(eval $(call BuildPackage,haserl-lua))