summaryrefslogtreecommitdiffhomepage
path: root/contrib/package/haserl-lua/Makefile
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-04-06 18:23:58 +0000
committerSteven Barth <steven@midlink.org>2008-04-06 18:23:58 +0000
commit98656c6b54cff3a098d89d2b722551def52f6510 (patch)
tree82d94adee5b2aa20b86f03e345dd0464a33eb727 /contrib/package/haserl-lua/Makefile
parent9e67df179f28e62045d5452134e23bebb9eab72f (diff)
* Cleaning up package definitions and sources to better harmonize with OpenWRT-packages
Diffstat (limited to 'contrib/package/haserl-lua/Makefile')
-rw-r--r--contrib/package/haserl-lua/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/contrib/package/haserl-lua/Makefile b/contrib/package/haserl-lua/Makefile
index 9b5b198fc1..6d2a4f131d 100644
--- a/contrib/package/haserl-lua/Makefile
+++ b/contrib/package/haserl-lua/Makefile
@@ -3,18 +3,16 @@
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
-#
-# $Id: Makefile 1719 2008-03-24 16:07:38Z Cyrus $
include $(TOPDIR)/rules.mk
-PKG_NAME:=haserl
+PKG_NAME:=haserl-lua
PKG_VERSION:=0.9.23
PKG_RELEASE:=1
-PKG_SOURCE:=haserl-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/haserl
-PKG_MD5SUM:=31d1f505afe3ba1b351e18612aa57a70
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=https://dev.leipzig.freifunk.net/svn/ff-luci/trunk/contrib/package-source/
+PKG_MD5SUM:=f3a0f329904791c5662d93638f92bdfd
include $(INCLUDE_DIR)/package.mk
@@ -34,6 +32,8 @@ define Package/haserl-lua/install
$(INSTALL_DIR) $(1)/usr/bin
$(STRIP) $(PKG_BUILD_DIR)/src/haserl
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/haserl $(1)/usr/bin/
+ echo "Replaces: haserl" >> $(1)/CONTROL/control
+ echo "Conflicts: haserl" >> $(1)/CONTROL/control
endef
$(eval $(call BuildPackage,haserl-lua))