summaryrefslogtreecommitdiffhomepage
path: root/contrib/package/haserl-lua/Makefile
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-06-15 18:54:44 +0000
committerSteven Barth <steven@midlink.org>2008-06-15 18:54:44 +0000
commit6fa9ec035b262c5aec11962329aa3d6da72c5af9 (patch)
tree991aeb2eef60130c4fc41428552912c582cd2593 /contrib/package/haserl-lua/Makefile
parentd5d8e8c86724b4a154b7af9c94e0eec70a485868 (diff)
* Removed support for Haserl
Diffstat (limited to 'contrib/package/haserl-lua/Makefile')
-rw-r--r--contrib/package/haserl-lua/Makefile40
1 files changed, 0 insertions, 40 deletions
diff --git a/contrib/package/haserl-lua/Makefile b/contrib/package/haserl-lua/Makefile
deleted file mode 100644
index 31158215a8..0000000000
--- a/contrib/package/haserl-lua/Makefile
+++ /dev/null
@@ -1,40 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=haserl-lua
-PKG_VERSION:=0.9.24
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://dev.leipzig.freifunk.net/svn/ff-luci/trunk/contrib/package-source/ \
- http://firmware.freifunk-halle.net/luci/package-source/
-PKG_MD5SUM:=b004005594b84e35839b1d5c330f8e03
-
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/haserl-lua
- SECTION:=utils
- CATEGORY:=Utilities
- TITLE:=A CGI wrapper to embed shell scripts in HTML documents
- URL:=http://haserl.sourceforge.net/
- DEPENDS:=+liblua
-endef
-
-CONFIGURE_ARGS += \
- --with-lua
-
-define Package/haserl-lua/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(STRIP) $(PKG_BUILD_DIR)/src/haserl
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/haserl $(1)/usr/bin/
- echo "Replaces: haserl" >> $(1)/CONTROL/control
- echo "Conflicts: haserl" >> $(1)/CONTROL/control
-endef
-
-$(eval $(call BuildPackage,haserl-lua))