summaryrefslogtreecommitdiffhomepage
path: root/contrib/package/haserl-devel/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2008-03-02 21:52:58 +0000
committerJo-Philipp Wich <jow@openwrt.org>2008-03-02 21:52:58 +0000
commit3f5de3273c9e103b4909802e339db06fe0b53312 (patch)
tree793ef66c9456665f7b472e214d79b1078fccebe8 /contrib/package/haserl-devel/Makefile
* new project: ff-luci - Freifunk Lua Configuration Interface
Diffstat (limited to 'contrib/package/haserl-devel/Makefile')
-rw-r--r--contrib/package/haserl-devel/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/contrib/package/haserl-devel/Makefile b/contrib/package/haserl-devel/Makefile
new file mode 100644
index 0000000000..3621c4691b
--- /dev/null
+++ b/contrib/package/haserl-devel/Makefile
@@ -0,0 +1,39 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=haserl
+PKG_VERSION:=0.9.22
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/haserl
+PKG_MD5SUM:=b791150f2e5704d03b1fb698f4edc6c0
+
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/haserl
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=A CGI wrapper to embed shell scripts in HTML documents
+ URL:=http://haserl.sourceforge.net/
+ DEPENDS:=+liblua
+endef
+
+CONFIGURE_ARGS += \
+ --with-lua
+
+define Package/haserl/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(STRIP) $(PKG_BUILD_DIR)/src/haserl
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/haserl $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,haserl))