summaryrefslogtreecommitdiffhomepage
path: root/contrib/package/freifunk-watchdog/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-05-04 16:54:45 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-05-04 16:54:45 +0000
commit214511aafc65d340174c93703efd1e158b076be1 (patch)
tree67d1dc34541ac85f7196fb2347ac16b921b51538 /contrib/package/freifunk-watchdog/Makefile
parentd9fd5a4c9e422f038260e645b227c416a2edf350 (diff)
contrib/package: add freifunk watchdog daemon
Diffstat (limited to 'contrib/package/freifunk-watchdog/Makefile')
-rw-r--r--contrib/package/freifunk-watchdog/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/contrib/package/freifunk-watchdog/Makefile b/contrib/package/freifunk-watchdog/Makefile
new file mode 100644
index 000000000..6d36d0958
--- /dev/null
+++ b/contrib/package/freifunk-watchdog/Makefile
@@ -0,0 +1,50 @@
+#
+# Copyright (C) 2009 Jo-Philipp Wich <xm@subsignal.org>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=freifunk-watchdog
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/freifunk-watchdog
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=Freifunk Ad-Hoc watchdog daemon
+endef
+
+define Package/freifunk-watchdog/description
+ A watchdog daemon that monitors wireless interfaces to ensure the correct bssid and channel.
+ The process will initiate a wireless restart as soon as it detects a bssid or channel mismatch.
+endef
+
+define Build/Prepare
+ mkdir -p $(PKG_BUILD_DIR)
+ $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ CC="$(TARGET_CC)" \
+ CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
+ LDFLAGS="$(TARGET_LDFLAGS)"
+endef
+
+define Package/freifunk-watchdog/install
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) ./files/freifunk-watchdog.init $(1)/etc/init.d/freifunk-watchdog
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/ffwatchd $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,freifunk-watchdog))