summaryrefslogtreecommitdiffhomepage
path: root/contrib/package/freifunk-gwcheck/Makefile
diff options
context:
space:
mode:
authorManuel Munz <freifunk@somakoma.de>2011-09-23 19:23:18 +0000
committerManuel Munz <freifunk@somakoma.de>2011-09-23 19:23:18 +0000
commitd8e4734b23016cea5c5099f84a7f2ffbab8e6216 (patch)
treecb1f06928a006357b7e0a532dd0765dc76ffc87d /contrib/package/freifunk-gwcheck/Makefile
parent9ed39e1431395bb84c486df94bc0a3660d7f0936 (diff)
contrib/package: Add freifunk-gwcheck to replace the gateway-check in modules/freifunk
Diffstat (limited to 'contrib/package/freifunk-gwcheck/Makefile')
-rw-r--r--contrib/package/freifunk-gwcheck/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/contrib/package/freifunk-gwcheck/Makefile b/contrib/package/freifunk-gwcheck/Makefile
new file mode 100644
index 0000000000..4922c236c8
--- /dev/null
+++ b/contrib/package/freifunk-gwcheck/Makefile
@@ -0,0 +1,39 @@
+# Copyright (C) 2011 Manuel Munz <freifunk at somakoma de>
+# This is free software, licensed under the Apache 2.0 license.
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=freifunk-gwcheck
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/freifunk-gwcheck
+ SECTION:=luci
+ CATEGORY:=LuCI
+ SUBMENU:=Freifunk
+ TITLE:=Freifunk gateway check script
+ DEPENDS:=+firewall +ip +iptables-mod-ipopt
+endef
+
+define Package/freifunk-gwcheck/description
+ This script periodically checks if internet is available via your own gateway. If it detects that it is broken, then the defaultroute is removed from the main table and temporarilly placed in table gw-check until your internet works again. Config file is /etc/config/freifunk-gwcheck.
+endef
+
+define Build/Prepare
+ mkdir -p $(PKG_BUILD_DIR)
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+endef
+
+define Package/freifunk-gwcheck/install
+ $(CP) ./files/* $(1)/
+endef
+
+$(eval $(call BuildPackage,freifunk-gwcheck))