summaryrefslogtreecommitdiffhomepage
path: root/contrib/package/freifunk-firewall
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-06-16 23:05:11 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-06-16 23:05:11 +0000
commite2e59b6895fdce3618e9b04515e0a99c7b63fbb4 (patch)
treea9bff5f77bed0e27340a4d327016e01351c3a947 /contrib/package/freifunk-firewall
parentac45654a16e7c5e2416e3566e049de586cebc2f5 (diff)
contrib/package: fix postinstall of freifunk-firewall
Diffstat (limited to 'contrib/package/freifunk-firewall')
-rw-r--r--contrib/package/freifunk-firewall/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/contrib/package/freifunk-firewall/Makefile b/contrib/package/freifunk-firewall/Makefile
index d2ae07588..24be151e4 100644
--- a/contrib/package/freifunk-firewall/Makefile
+++ b/contrib/package/freifunk-firewall/Makefile
@@ -37,12 +37,13 @@ endef
define Package/freifunk-firewall/postinst
#!/bin/sh
-
-if ! grep -q /etc/firewall.freifunk /etc/config/firewall; then
- uci add firewall include >/dev/null
- uci set firewall.@include[-1].path=/etc/firewall.freifunk
- uci commit firewall
-fi
+[ -n "${IPKG_INSTROOT}" ] || {
+ if ! grep -q /etc/firewall.freifunk /etc/config/firewall; then
+ uci add firewall include >/dev/null
+ uci set firewall.@include[-1].path=/etc/firewall.freifunk
+ uci commit firewall
+ fi
+}
endef
define Package/freifunk-firewall/install