summaryrefslogtreecommitdiffhomepage
path: root/contrib/package/ffluci/Makefile
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-04-05 15:12:02 +0000
committerSteven Barth <steven@midlink.org>2008-04-05 15:12:02 +0000
commit6adf7451cff19b48dd75762e9242becb8a51e247 (patch)
treea3f82935db2ce9ef68bc59fa1d973d8b2c33e167 /contrib/package/ffluci/Makefile
parent55c2ac261f7bc865cf7fc2abe6c69ffd87a098ac (diff)
* Added own custom version of Lua
* Updated Lua to produce architecture-independent bytecode * Updated Lua to load bytecode from different endianess * Updated Lua to use optimized integer arithmetic for CPUs without an FPU * Updated haserl-lua to fit to optimized Lua version (hopefully this should fix: "bad header in precompiled chunk" on some platforms) * Luci core will now be bytecompiled and stripped by default to save disk space and CPU time
Diffstat (limited to 'contrib/package/ffluci/Makefile')
-rw-r--r--contrib/package/ffluci/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/contrib/package/ffluci/Makefile b/contrib/package/ffluci/Makefile
index 42fffb6ed..9ec4f311a 100644
--- a/contrib/package/ffluci/Makefile
+++ b/contrib/package/ffluci/Makefile
@@ -15,7 +15,7 @@ PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-MAKE_ACTION:=dist-source
+MAKE_ACTION:=dist-compile LUAC=$(BUILD_DIR_HOST)/lua-luci/luac
include $(INCLUDE_DIR)/package.mk
@@ -23,7 +23,7 @@ define Package/ffluci
SECTION:=admin
CATEGORY:=Administration
TITLE:=FFLuCI
- DEPENDS:=+liblua +luaposix +haserl-lua
+ DEPENDS:=+luaposix +haserl-lua
MAINTAINER:=Steven Barth <steven-at-midlink-dot-org>
endef