summaryrefslogtreecommitdiffhomepage
path: root/contrib/luaposix
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-06-14 14:12:12 +0000
committerSteven Barth <steven@midlink.org>2008-06-14 14:12:12 +0000
commit855b7582d3576f45693e3a48fdb253c813cf4dce (patch)
treeb912f63dc43f3b696385083542c801dba8c53976 /contrib/luaposix
parent50fd29841540bb8b1735291b72853454679e9e62 (diff)
* Rewrote Luci to be coroutine-safe allowing the use of non-forking webservers
* Setting base version to 0.7
Diffstat (limited to 'contrib/luaposix')
-rw-r--r--contrib/luaposix/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/contrib/luaposix/Makefile b/contrib/luaposix/Makefile
index ec832cc2d..c357f5d2c 100644
--- a/contrib/luaposix/Makefile
+++ b/contrib/luaposix/Makefile
@@ -34,8 +34,8 @@ $(LUAPOSIX_DIR)/.patched: $(LUAPOSIX_DIR)/.prepared $(LUAPOSIX_PATCHDIR)/series
compile: $(LUAPOSIX_DIR)/.patched
$(MAKE) -C $(LUAPOSIX_DIR) CC=$(CC) CFLAGS="$(CFLAGS) $(LUA_CFLAGS)" LDFLAGS="$(LDFLAGS) $(LUA_SHLIBS)" OS="$(OS)"
- mkdir -p dist/usr/lib/lua
- cp $(LUAPOSIX_DIR)/posix.so dist/usr/lib/lua/
+ mkdir -p dist$(LUA_LIBRARYDIR)
+ cp $(LUAPOSIX_DIR)/posix.so dist$(LUA_LIBRARYDIR)
luasource:
compile-all: compile