summaryrefslogtreecommitdiffhomepage
path: root/contrib/axtls/patches
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2009-06-20 07:14:26 +0000
committerSteven Barth <steven@midlink.org>2009-06-20 07:14:26 +0000
commite2f2d1a63406da4fb5ff870394035bf60760398a (patch)
tree777ed3fcc14dec0bec19e1a15c55b52644cbbf1e /contrib/axtls/patches
parent6088f2b3fe5384f8f0bae1a7842ff8ed98a0f1ee (diff)
Drop axtls in contrib (obsolete)
Diffstat (limited to 'contrib/axtls/patches')
-rw-r--r--contrib/axtls/patches/001-ld-fix.patch12
-rw-r--r--contrib/axtls/patches/002-httpd-fix.patch12
-rw-r--r--contrib/axtls/patches/003-content-type.patch37
-rw-r--r--contrib/axtls/patches/004-cgi-nph-mode.patch20
4 files changed, 0 insertions, 81 deletions
diff --git a/contrib/axtls/patches/001-ld-fix.patch b/contrib/axtls/patches/001-ld-fix.patch
deleted file mode 100644
index 2456007055..0000000000
--- a/contrib/axtls/patches/001-ld-fix.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urb axTLS.orig/ssl/Makefile axTLS/ssl/Makefile
---- axTLS.orig/ssl/Makefile 2008-11-09 00:58:43.000000000 +0000
-+++ axTLS/ssl/Makefile 2008-11-09 00:58:57.000000000 +0000
-@@ -96,7 +96,7 @@
-
- $(TARGET2) : $(OBJ)
- ifndef CONFIG_PLATFORM_CYGWIN
-- $(LD) $(LDFLAGS) $(LDSHARED) -Wl,-soname,$(LIBMAJOR) -o $(AXTLS_HOME)/$(STAGE)/$(LIBMINOR) $(CRYPTO_OBJ) $(OBJ)
-+ $(LD) $(LDFLAGS) $(LDSHARED) -o $(AXTLS_HOME)/$(STAGE)/$(LIBMINOR) $(CRYPTO_OBJ) $(OBJ)
- cd $(AXTLS_HOME)/$(STAGE); ln -sf $(LIBMINOR) $(LIBMAJOR); ln -sf $(LIBMAJOR) $(BASETARGET); cd -
- else
- $(LD) $(LDFLAGS) $(LDSHARED) -o $(AXTLS_HOME)/$(STAGE)/cygaxtls.dll \
diff --git a/contrib/axtls/patches/002-httpd-fix.patch b/contrib/axtls/patches/002-httpd-fix.patch
deleted file mode 100644
index e6fd152d8a..0000000000
--- a/contrib/axtls/patches/002-httpd-fix.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urb axTLS.orig/httpd/Makefile axTLS/httpd/Makefile
---- axTLS.orig/httpd/Makefile 2008-11-09 00:58:44.000000000 +0000
-+++ axTLS/httpd/Makefile 2008-11-09 01:29:55.000000000 +0000
-@@ -95,7 +95,7 @@
- ifndef CONFIG_PLATFORM_WIN32
-
- $(TARGET): $(OBJ) $(AXTLS_HOME)/$(STAGE)/libaxtls.a
-- $(LD) $(LDFLAGS) -o $@ $(OBJ) $(LIBS)
-+ $(CC) $(LDFLAGS) -o $@ $(OBJ) $(LIBS)
- ifdef CONFIG_STRIP_UNWANTED_SECTIONS
- strip --remove-section=.comment $(TARGET)
- endif
diff --git a/contrib/axtls/patches/003-content-type.patch b/contrib/axtls/patches/003-content-type.patch
deleted file mode 100644
index 476890cf16..0000000000
--- a/contrib/axtls/patches/003-content-type.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-diff -urb axTLS.orig/httpd/axhttp.h axTLS/httpd/axhttp.h
---- axTLS.orig/httpd/axhttp.h 2008-11-09 00:58:44.000000000 +0000
-+++ axTLS/httpd/axhttp.h 2008-11-09 02:33:44.000000000 +0000
-@@ -91,6 +91,7 @@
- uint8_t is_lua;
- #endif
- int content_length;
-+ char content_type[MAXREQUESTLENGTH];
- char remote_addr[MAXREQUESTLENGTH];
- char uri_request[MAXREQUESTLENGTH];
- char uri_path_info[MAXREQUESTLENGTH];
-diff -urb axTLS.orig/httpd/proc.c axTLS/httpd/proc.c
---- axTLS.orig/httpd/proc.c 2008-11-09 00:58:44.000000000 +0000
-+++ axTLS/httpd/proc.c 2008-11-09 02:43:32.000000000 +0000
-@@ -129,6 +129,10 @@
-
- my_strncpy(cn->server_name, value, MAXREQUESTLENGTH);
- }
-+ else if (strcmp(buf, "Content-Type:") == 0 )
-+ {
-+ my_strncpy(cn->content_type, value, MAXREQUESTLENGTH);
-+ }
- else if (strcmp(buf, "Connection:") == 0 && strcmp(value, "close") == 0)
- {
- cn->close_when_done = 1;
-@@ -673,8 +677,9 @@
- type = "POST";
- sprintf(cgienv[cgi_index++],
- "CONTENT_LENGTH=%d", cn->content_length);
-- strcpy(cgienv[cgi_index++], /* hard-code? */
-- "CONTENT_TYPE=application/x-www-form-urlencoded");
-+ snprintf(cgienv[cgi_index++], MAXREQUESTLENGTH,
-+ "CONTENT_TYPE=%s", cn->content_type);
-+
- break;
- }
-
diff --git a/contrib/axtls/patches/004-cgi-nph-mode.patch b/contrib/axtls/patches/004-cgi-nph-mode.patch
deleted file mode 100644
index 2b6cc5c434..0000000000
--- a/contrib/axtls/patches/004-cgi-nph-mode.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- axTLS/httpd/proc.c 2008-11-13 14:05:02.000000000 +0100
-+++ axTLS.new/httpd/proc.c 2008-11-13 16:07:12.000000000 +0100
-@@ -556,13 +556,13 @@
- int tmp_stdout;
- #endif
-
-- snprintf(cgienv[0], MAXREQUESTLENGTH,
-+ if (cn->reqtype == TYPE_HEAD)
-+ {
-+ snprintf(cgienv[0], MAXREQUESTLENGTH,
- HTTP_VERSION" 200 OK\nServer: %s\n%s",
- server_version, (cn->reqtype == TYPE_HEAD) ? "\n" : "");
-- special_write(cn, cgienv[0], strlen(cgienv[0]));
-+ special_write(cn, cgienv[0], strlen(cgienv[0]));
-
-- if (cn->reqtype == TYPE_HEAD)
-- {
- removeconnection(cn);
- return;
- }