summaryrefslogtreecommitdiffhomepage
path: root/collections
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2017-01-31 16:47:12 +0200
committerHannu Nyman <hannu.nyman@iki.fi>2017-01-31 16:47:12 +0200
commitb6341bd197aed9640c4d0dcff73019e045978df0 (patch)
treea915186635eef87b148b3adaadd7fb6be5675444 /collections
parentd85f7a8a00bfa80ab1e8613446eb4d722dcd6ea5 (diff)
luci-ssl-openssl: use OpenSSL for key generation, drop px5g
Replace a dependency for px5g with openssl-util. Both LEDE and Openwrt have now uhttpd versions that can generate keys with OpenSSL cmd tools if px5g is not found. This change enables an "OpenSSL-only" version of LuCI without mbedTLS/PolarSSL. (Note: if px5g is found, uhttpd will prefer that.) Relevant commits in uhttpd: LEDE: https://github.com/lede-project/source/commit/3c4858eeb2bbb3107f87bb3be07d5c172c8e0ef9 https://github.com/lede-project/source/commit/82132540a3efbc98f8f4379b26d4b4541013e69d https://github.com/lede-project/source/commit/9097dc5ad844c336020be11085e1c8c80390ac9c Openwrt: https://github.com/openwrt/openwrt/commit/6ec32832d25335355d205c4601d4a8ca5dfd6808 Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Diffstat (limited to 'collections')
-rw-r--r--collections/luci-ssl-openssl/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/collections/luci-ssl-openssl/Makefile b/collections/luci-ssl-openssl/Makefile
index b5f4b091b..d1e752e8b 100644
--- a/collections/luci-ssl-openssl/Makefile
+++ b/collections/luci-ssl-openssl/Makefile
@@ -11,10 +11,10 @@ LUCI_BASENAME:=ssl-openssl
LUCI_TITLE:=LuCI with HTTPS support (OpenSSL as SSL backend)
LUCI_DESCRIPTION:=LuCI with OpenSSL as the SSL backend (libustream-openssl). \
- Note: px5g still requires libmbedtls (in LEDE) or libpolarssl (in Openwrt). \
- In LEDE it is also possible to replace px5g with openssl-util as uhttpd can \
- also generate keys with openssl commandline tools if px5g is not installed.
-LUCI_DEPENDS:=+luci +libustream-openssl +px5g
+ OpenSSL cmd tools (openssl-util) are used by uhttpd for SSL key generation \
+ instead of the default px5g. (If px5g is installed, uhttpd will prefer that.)
+
+LUCI_DEPENDS:=+luci +libustream-openssl +openssl-util
include ../../luci.mk