summaryrefslogtreecommitdiffhomepage
path: root/collections
diff options
context:
space:
mode:
authorAnsuel Smith <ansuelsmth@gmail.com>2018-06-07 18:42:02 +0200
committerAnsuel Smith <ansuelsmth@gmail.com>2018-06-11 22:23:09 +0200
commit90bf08af829a8e13c3caf6a389bff5212d5204dc (patch)
tree20e998331847c4cb2b6931aaed8333b5d6838ad6 /collections
parent5452cc214ed5ef9b6a25711754ed97384166f924 (diff)
luci-nginx: add nginx metapackages
Create a metapackage with nginx as default webserver instead of uhttpd Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
Diffstat (limited to 'collections')
-rw-r--r--collections/luci-nginx/Makefile23
-rw-r--r--collections/luci-ssl-nginx/Makefile19
-rw-r--r--collections/luci-ssl-openssl-nginx/Makefile21
-rw-r--r--collections/luci/Makefile3
4 files changed, 65 insertions, 1 deletions
diff --git a/collections/luci-nginx/Makefile b/collections/luci-nginx/Makefile
new file mode 100644
index 000000000..2d7de3899
--- /dev/null
+++ b/collections/luci-nginx/Makefile
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2008-2014 The LuCI Team <luci@lists.subsignal.org>
+#
+# This is free software, licensed under the Apache License, Version 2.0 .
+#
+
+include $(TOPDIR)/rules.mk
+
+LUCI_TYPE:=col
+LUCI_BASENAME:=nginx
+
+LUCI_TITLE:=LuCI interface with Nginx as Webserver
+LUCI_DESCRIPTION:=Standard OpenWrt set including full admin with ppp support and the default Bootstrap theme
+LUCI_DEPENDS:= \
+ +nginx +luci-mod-admin-full +luci-theme-bootstrap \
+ +luci-app-firewall +luci-proto-ppp +libiwinfo-lua +IPV6:luci-proto-ipv6 \
+ +rpcd-mod-rrdns
+
+PKG_LICENSE:=Apache-2.0
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature
diff --git a/collections/luci-ssl-nginx/Makefile b/collections/luci-ssl-nginx/Makefile
new file mode 100644
index 000000000..45ae8b21d
--- /dev/null
+++ b/collections/luci-ssl-nginx/Makefile
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2008-2016 The LuCI Team
+#
+# This is free software, licensed under the Apache License, Version 2.0 .
+#
+
+include $(TOPDIR)/rules.mk
+
+LUCI_TYPE:=col
+LUCI_BASENAME:=ssl
+
+LUCI_TITLE:=LuCI with HTTPS support (mbedTLS as SSL backend)
+LUCI_DEPENDS:=+luci-nginx +libustream-mbedtls +px5g
+
+PKG_LICENSE:=Apache-2.0
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature
diff --git a/collections/luci-ssl-openssl-nginx/Makefile b/collections/luci-ssl-openssl-nginx/Makefile
new file mode 100644
index 000000000..f0e9b31c8
--- /dev/null
+++ b/collections/luci-ssl-openssl-nginx/Makefile
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2016 The LuCI Team
+#
+# This is free software, licensed under the Apache License, Version 2.0 .
+#
+
+include $(TOPDIR)/rules.mk
+
+LUCI_TYPE:=col
+LUCI_BASENAME:=ssl-openssl
+
+LUCI_TITLE:=LuCI with HTTPS support (OpenSSL as SSL backend)
+LUCI_DESCRIPTION:=LuCI with OpenSSL as the SSL backend (libustream-openssl). \
+ OpenSSL cmd tools (openssl-util) are used by uhttpd for SSL key generation \
+ instead of the default px5g. (If px5g is installed, uhttpd will prefer that.)
+
+LUCI_DEPENDS:=+luci-nginx +libustream-openssl +openssl-util
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature
diff --git a/collections/luci/Makefile b/collections/luci/Makefile
index 9b495c318..3c765c396 100644
--- a/collections/luci/Makefile
+++ b/collections/luci/Makefile
@@ -9,7 +9,8 @@ include $(TOPDIR)/rules.mk
LUCI_TYPE:=col
LUCI_BASENAME:=luci
-LUCI_TITLE:=Standard OpenWrt set including full admin with ppp support and the default Bootstrap theme
+LUCI_TITLE:=LuCI interface with Uhttpd as Webserver (default)
+LUCI_DESCRIPTION:=Standard OpenWrt set including full admin with ppp support and the default Bootstrap theme
LUCI_DEPENDS:= \
+uhttpd +uhttpd-mod-ubus +luci-mod-admin-full +luci-theme-bootstrap \
+luci-app-firewall +luci-proto-ppp +libiwinfo-lua +IPV6:luci-proto-ipv6 \