summaryrefslogtreecommitdiffhomepage
path: root/collections/luci-nginx/Makefile
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2018-06-12 19:57:22 +0300
committerGitHub <noreply@github.com>2018-06-12 19:57:22 +0300
commitb5a43cf87d3f30e0230cc4f0701de97591af90c7 (patch)
tree0e33d52e48dc9d96b5355d80ed725618bae80c69 /collections/luci-nginx/Makefile
parent8798bb22b20def9b2ed045792f3470ecba78ba22 (diff)
parent90bf08af829a8e13c3caf6a389bff5212d5204dc (diff)
Merge pull request #1862 from Ansuel/lucidep
luci-nginx: add nginx metapackages
Diffstat (limited to 'collections/luci-nginx/Makefile')
-rw-r--r--collections/luci-nginx/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/collections/luci-nginx/Makefile b/collections/luci-nginx/Makefile
new file mode 100644
index 0000000000..2d7de3899a
--- /dev/null
+++ b/collections/luci-nginx/Makefile
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2008-2014 The LuCI Team <luci@lists.subsignal.org>
+#
+# This is free software, licensed under the Apache License, Version 2.0 .
+#
+
+include $(TOPDIR)/rules.mk
+
+LUCI_TYPE:=col
+LUCI_BASENAME:=nginx
+
+LUCI_TITLE:=LuCI interface with Nginx as Webserver
+LUCI_DESCRIPTION:=Standard OpenWrt set including full admin with ppp support and the default Bootstrap theme
+LUCI_DEPENDS:= \
+ +nginx +luci-mod-admin-full +luci-theme-bootstrap \
+ +luci-app-firewall +luci-proto-ppp +libiwinfo-lua +IPV6:luci-proto-ipv6 \
+ +rpcd-mod-rrdns
+
+PKG_LICENSE:=Apache-2.0
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature