summaryrefslogtreecommitdiffhomepage
path: root/build
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-04-05 01:05:01 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-04-05 01:05:01 +0000
commitbaa3404ab3e4c56b3583c91af58e554df2f42da2 (patch)
tree791a48ab67bf2163b452541faf2309908e0a7593 /build
parent9835296ba2623b5c87624da3a8ba5f43595297d0 (diff)
trunk: add gzip build target
Diffstat (limited to 'build')
-rw-r--r--build/module.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/build/module.mk b/build/module.mk
index 8f3964ad6..93f52689c 100644
--- a/build/module.mk
+++ b/build/module.mk
@@ -37,6 +37,9 @@ luastrip: luasource
luacompile: luasource
for i in $$(find dist -name *.lua -not -name debug.lua); do $(LUAC) $(LUAC_OPTIONS) -o $$i $$i; done
+luagzip: luacompile
+ for i in $$(find dist -name *.lua -not -name debug.lua); do gzip -9 $$i; done
+
luaclean:
rm -rf dist