summaryrefslogtreecommitdiffhomepage
path: root/build
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-12-09 21:02:52 +0000
committerSteven Barth <steven@midlink.org>2008-12-09 21:02:52 +0000
commita02f12cf2e2becfe976faa6ff1e5a585c78a513d (patch)
tree9c5b1e4f06559f198e734a2915c330721f2b38fc /build
parentf7a3e34955fdcf9678fd0a5e18c8b06b6fc6b244 (diff)
Compatbility with non-Debian distros
Diffstat (limited to 'build')
-rw-r--r--build/gccconfig.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/build/gccconfig.mk b/build/gccconfig.mk
index bb308af8d..d6af2c3e6 100644
--- a/build/gccconfig.mk
+++ b/build/gccconfig.mk
@@ -1,8 +1,8 @@
OS ?= $(shell uname)
-LUA_SHLIBS = $(shell pkg-config --silence-errors --libs lua5.1)
+LUA_SHLIBS = $(shell pkg-config --silence-errors --libs lua5.1 || pkg-config --silence-errors --libs lua)
LUA_LIBS = $(if $(LUA_SHLIBS),$(LUA_SHLIBS),$(firstword $(wildcard /usr/lib/liblua.a /usr/local/lib/liblua.a /opt/local/lib/liblua.a)))
-LUA_CFLAGS = $(shell pkg-config --silence-errors --cflags lua5.1)
+LUA_CFLAGS = $(shell pkg-config --silence-errors --cflags lua5.1 || pkg-config --silence-errors --cflags lua)
CC = gcc
AR = ar