summaryrefslogtreecommitdiffhomepage
path: root/build
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2009-03-12 13:06:19 +0000
committerSteven Barth <steven@midlink.org>2009-03-12 13:06:19 +0000
commit35f40376c36805c4a023015d4cf95f1fa8adcb04 (patch)
tree61b70a4fadf3dc6a4367df89d46f7c2751495da0 /build
parente401b4a620ee968d4a191cb9c86ff0adde215a1e (diff)
nixio: FreeBSD compatibility #1
Diffstat (limited to 'build')
-rw-r--r--build/gccconfig.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/build/gccconfig.mk b/build/gccconfig.mk
index d6af2c3e6..1557c3b1e 100644
--- a/build/gccconfig.mk
+++ b/build/gccconfig.mk
@@ -1,8 +1,8 @@
OS ?= $(shell uname)
-LUA_SHLIBS = $(shell pkg-config --silence-errors --libs lua5.1 || pkg-config --silence-errors --libs lua)
+LUA_SHLIBS = $(shell pkg-config --silence-errors --libs lua5.1 || pkg-config --silence-errors --libs lua-5.1 || pkg-config --silence-errors --libs lua)
LUA_LIBS = $(if $(LUA_SHLIBS),$(LUA_SHLIBS),$(firstword $(wildcard /usr/lib/liblua.a /usr/local/lib/liblua.a /opt/local/lib/liblua.a)))
-LUA_CFLAGS = $(shell pkg-config --silence-errors --cflags lua5.1 || pkg-config --silence-errors --cflags lua)
+LUA_CFLAGS = $(shell pkg-config --silence-errors --cflags lua5.1 || pkg-config --silence-errors --cflags lua-5.1 || pkg-config --silence-errors --cflags lua)
CC = gcc
AR = ar