summaryrefslogtreecommitdiffhomepage
path: root/build
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /build
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'build')
-rwxr-xr-xbuild/mkversion.sh41
1 files changed, 0 insertions, 41 deletions
diff --git a/build/mkversion.sh b/build/mkversion.sh
deleted file mode 100755
index 3680008df..000000000
--- a/build/mkversion.sh
+++ /dev/null
@@ -1,41 +0,0 @@
-#!/bin/sh
-
-if svn info >/dev/null 2>/dev/null; then
- if [ "${4%%/*}" = "branches" ]; then
- variant="LuCI ${4##*[-/]} Branch"
- elif [ "${4%%/*}" = "tags" ]; then
- variant="LuCI ${4##*[-/]} Release"
- else
- variant="LuCI Trunk"
- fi
-elif git status >/dev/null 2>/dev/null; then
- tag="$(git describe --tags 2>/dev/null)"
- branch="$(git symbolic-ref --short -q HEAD 2>/dev/null)"
-
- if [ -n "$tag" ]; then
- variant="LuCI $tag Release"
- elif [ "$branch" != "master" ]; then
- variant="LuCI ${branch##*-} Branch"
- else
- variant="LuCI Master"
- fi
-else
- variant="LuCI"
-fi
-
-cat <<EOF > $1
-local pcall, dofile, _G = pcall, dofile, _G
-
-module "luci.version"
-
-if pcall(dofile, "/etc/openwrt_release") and _G.DISTRIB_DESCRIPTION then
- distname = ""
- distversion = _G.DISTRIB_DESCRIPTION
-else
- distname = "${2:-OpenWrt}"
- distversion = "${3:-Development Snapshot}"
-end
-
-luciname = "$variant"
-luciversion = "${5:-svn}"
-EOF