summaryrefslogtreecommitdiffhomepage
path: root/build
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-06-02 21:01:59 +0000
committerSteven Barth <steven@midlink.org>2008-06-02 21:01:59 +0000
commitd76980c1947241db2104dbd759adcfc85ee2e435 (patch)
tree93bce27224dc8e732bd3ca08470068da73f3c939 /build
parent561b0cfaa3fb8163d9ec74a3f96fd5b22ad54f33 (diff)
* Don't override environment variables in Makefile
Diffstat (limited to 'build')
-rw-r--r--build/gccconfig.mk30
1 files changed, 15 insertions, 15 deletions
diff --git a/build/gccconfig.mk b/build/gccconfig.mk
index 0e4de2795..77bcf3674 100644
--- a/build/gccconfig.mk
+++ b/build/gccconfig.mk
@@ -1,22 +1,22 @@
OS ?= $(shell uname)
-LUA_SHLIBS = $(shell pkg-config --silence-errors --libs lua5.1)
-LUA_LIBS = $(if $(LUA_SHLIBS),$(LUA_SHLIBS),$(firstword $(wildcard /usr/lib/liblua.a /usr/local/lib/liblua.a /opt/local/lib/liblua.a)))
-LUA_CFLAGS = $(shell pkg-config --silence-errors --cflags lua5.1)
+LUA_SHLIBS ?= $(shell pkg-config --silence-errors --libs lua5.1)
+LUA_LIBS ?= $(if $(LUA_SHLIBS),$(LUA_SHLIBS),$(firstword $(wildcard /usr/lib/liblua.a /usr/local/lib/liblua.a /opt/local/lib/liblua.a)))
+LUA_CFLAGS ?= $(shell pkg-config --silence-errors --cflags lua5.1)
-CC = gcc
-AR = ar
-RANLIB = ranlib
-CFLAGS = -O2
-FPIC = -fPIC
-EXTRA_CFLAGS = --std=gnu99
-WFLAGS = -Wall -Werror -pedantic
-CPPFLAGS =
-COMPILE = $(CC) $(CPPFLAGS) $(CFLAGS) $(EXTRA_CFLAGS) $(WFLAGS)
+CC ?= gcc
+AR ?= ar
+RANLIB ?= ranlib
+CFLAGS ?= -O2
+FPIC ?= -fPIC
+EXTRA_CFLAGS ?= --std=gnu99
+WFLAGS ?= -Wall -Werror -pedantic
+CPPFLAGS ?=
+COMPILE ?= $(CC) $(CPPFLAGS) $(CFLAGS) $(EXTRA_CFLAGS) $(WFLAGS)
ifeq ($(OS),Darwin)
- SHLIB_FLAGS = -bundle -undefined dynamic_lookup
+ SHLIB_FLAGS ?= -bundle -undefined dynamic_lookup
else
- SHLIB_FLAGS = -shared
+ SHLIB_FLAGS ?= -shared
endif
-LINK = $(CC)
+LINK ?= $(CC)