summaryrefslogtreecommitdiffhomepage
path: root/build
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-07-19 10:27:23 +0000
committerSteven Barth <steven@midlink.org>2008-07-19 10:27:23 +0000
commit3b7e4eaaf8bb2970c0488c39695e0179d5a78f69 (patch)
treec60dc0b6e0e14e0acaa0bcbb360213bf3777af8a /build
parent2213c82b47e09373f48950763409704660947f92 (diff)
Added non-stripped debug target for LuCI
Diffstat (limited to 'build')
-rw-r--r--build/module.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/build/module.mk b/build/module.mk
index 8e403a0b6..20fdb4376 100644
--- a/build/module.mk
+++ b/build/module.mk
@@ -20,6 +20,8 @@ luasource:
cp -a lua/* dist$(LUA_MODULEDIR) -R 2>/dev/null || true
cp -a htdocs/* dist$(HTDOCS) -R 2>/dev/null || true
for i in $$(find dist -name .svn); do rm $$i -rf; done
+
+luastrip: luasource
for i in $$(find dist -type f -name '*.lua'); do perl -e 'undef $$/; open( F, "< $$ARGV[0]" ) || die $$!; $$src = <F>; close F; $$src =~ s/--\[\[.*?\]\](--)?//gs; $$src =~ s/^\s*--.*?\n//gm; open( F, "> $$ARGV[0]" ) || die $$!; print F $$src; close F' $$i; done
luacompile: luasource