summaryrefslogtreecommitdiffhomepage
path: root/build
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-09-03 17:07:38 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-09-03 17:07:38 +0000
commit158f709af34f0ead5bfcacfefcf2f49caf610673 (patch)
treedf8e4942b81d0afd63510853cfee33e1b1a35a92 /build
parentde9048ff8c9ff89d5a1ff11380319a7a64444abf (diff)
build: Bail out the build if any lua compilation fails. (Patch from Fon-NG, http://trac.fonosfera.org/fon-ng/changeset/1867)
Diffstat (limited to 'build')
-rw-r--r--build/module.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/build/module.mk b/build/module.mk
index 7104ba5af..b69019c56 100644
--- a/build/module.mk
+++ b/build/module.mk
@@ -39,7 +39,7 @@ luastrip: luasource
for i in $$(find dist -type f -name '*.lua'); do perl -e 'undef $$/; open( F, "< $$ARGV[0]" ) || die $$!; $$src = <F>; close F; $$src =~ s/--\[\[.*?\]\](--)?//gs; $$src =~ s/^\s*--.*?\n//gm; open( F, "> $$ARGV[0]" ) || die $$!; print F $$src; close F' $$i; done
luacompile: luasource
- for i in $$(find dist -name *.lua -not -name debug.lua); do $(LUAC) $(LUAC_OPTIONS) -o $$i $$i; done
+ for i in $$(find dist -name *.lua -not -name debug.lua| sort); do if ! $(LUAC) $(LUAC_OPTIONS) -o $$i $$i; then echo "Error compiling $$i"; exit 1; fi; done
luaclean:
rm -rf dist