summaryrefslogtreecommitdiffhomepage
path: root/build
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-08-15 20:42:25 +0000
committerSteven Barth <steven@midlink.org>2008-08-15 20:42:25 +0000
commit8e4afe121087c05833ee7d567fe45f2ba270e54d (patch)
tree20d64661cd0c2bb67b2e440886ae3bae55b31f07 /build
parent1d4196b3ff1bceaa858ffbee637bf212d5b5d428 (diff)
Several escaping fixes
Updated XML translation system Use the new Table widget for DHCP leases
Diffstat (limited to 'build')
-rw-r--r--build/module.mk9
1 files changed, 5 insertions, 4 deletions
diff --git a/build/module.mk b/build/module.mk
index 3a947546b..f54037850 100644
--- a/build/module.mk
+++ b/build/module.mk
@@ -8,16 +8,16 @@ all: build
build: luabuild gccbuild
-luabuild: lua$(LUA_TARGET) i18n
+luabuild: i18n lua$(LUA_TARGET)
gccbuild: compile
compile:
clean: luaclean
-i18n: luasource
- [ -n "$(XSLTPROC)" ] && for i in dist$(LUCI_MODULEDIR)/i18n/*.xml; do [ -f "$$i" ]\
- && { $(XSLTPROC) $(MAKEPATH)i18n-lua-xhtml1.xsl $$i > $${i/.xml/.lua}; rm $$i; }; done || true
+i18n:
+ [ -n "$(XSLTPROC)" ] && for i in luasrc/i18n/*.xml; do [ -f "$$i" ]\
+ && $(XSLTPROC) $(MAKEPATH)i18n-lua-xhtml1.xsl $$i > $${i/.xml/.lua}; done || true
luasource:
mkdir -p dist$(LUA_MODULEDIR)
@@ -28,6 +28,7 @@ luasource:
cp -a lua/* dist$(LUA_MODULEDIR) -R 2>/dev/null || true
cp -a htdocs/* dist$(HTDOCS) -R 2>/dev/null || true
for i in $$(find dist -name .svn); do rm $$i -rf || true; done
+ for i in dist$(LUCI_MODULEDIR)/i18n/*.xml; do [ -f "$$i" ] && rm $$i; done || true
luastrip: luasource