summaryrefslogtreecommitdiffhomepage
path: root/build
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-05-19 02:50:52 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-05-19 02:50:52 +0000
commit4274b69a125dfbb49aff57920bd8d5511e8219f7 (patch)
tree632bfd132e571f11c40cbc33ccc6da9a21677aac /build
parentde7842fdd3beaa694cc0cba2275962ab11f1e07b (diff)
build: also prepare i18n directories
Diffstat (limited to 'build')
-rw-r--r--build/config.mk2
-rw-r--r--build/module.mk3
2 files changed, 3 insertions, 2 deletions
diff --git a/build/config.mk b/build/config.mk
index bac250d72..31279ba7d 100644
--- a/build/config.mk
+++ b/build/config.mk
@@ -7,10 +7,10 @@ LUA_LIBRARYDIR = /usr/lib/lua
LUCI_MODULEDIR = $(LUA_MODULEDIR)/luci
LUCI_LIBRARYDIR = $(LUA_LIBRARYDIR)/luci
+LUCI_I18NDIR = $(LUA_MODULEDIR)/luci/i18n
UVL_SCHEMEDIR = host/lib/uci/schema
HTDOCS = /www
LUA=$(shell which lua)
-XSLTPROC=$(shell which xsltproc)
diff --git a/build/module.mk b/build/module.mk
index 70d54dc85..ecc7a92f2 100644
--- a/build/module.mk
+++ b/build/module.mk
@@ -25,8 +25,9 @@ luasource:
cp -pR htdocs/* dist$(HTDOCS) 2>/dev/null || true
for i in $$(find dist -name .svn -or -name .gitignore); do rm -rf $$i || true; done
ifneq ($(PO),)
+ mkdir -p dist$(LUCI_I18NDIR)
for file in $(PO); do \
- cp $(HOST)/lua-po/$$file.$(if $(PO_LANG),$(PO_LANG),*).lua dist$(LUCI_MODULEDIR)/i18n/; \
+ cp $(HOST)/lua-po/$$file.$(if $(PO_LANG),$(PO_LANG),*).lua dist$(LUCI_I18NDIR)/ 2>/dev/null || true; \
done
endif