summaryrefslogtreecommitdiffhomepage
path: root/build
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-12-14 11:54:36 +0000
committerSteven Barth <steven@midlink.org>2008-12-14 11:54:36 +0000
commit082e30b1c4a1d3a90b0bb8317319e72b8b010a68 (patch)
treebcc47320786683d46c9918133eba10b9840832ec /build
parent239836b3bef9abc35a66b489881438b775231b1c (diff)
i18n: .xml should not overwrite .lua files if they are older
Diffstat (limited to 'build')
-rw-r--r--build/module.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/build/module.mk b/build/module.mk
index 18eda9d8b..8f3964ad6 100644
--- a/build/module.mk
+++ b/build/module.mk
@@ -16,7 +16,7 @@ compile:
clean: luaclean
i18n:
- [ -n "$(XSLTPROC)" ] && for i in luasrc/i18n/*.xml; do [ -f "$$i" ]\
+ [ -n "$(XSLTPROC)" ] && for i in luasrc/i18n/*.xml; do [ "$$i" -nt "$${i%%[.]xml}.lua" ]\
&& $(XSLTPROC) $(MAKEPATH)i18n-lua-xhtml1.xsl $$i > $${i%%[.]xml}.lua; done || true
luasource: