summaryrefslogtreecommitdiffhomepage
path: root/build
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-07-24 13:55:11 +0000
committerSteven Barth <steven@midlink.org>2008-07-24 13:55:11 +0000
commit7384e0e6b77518efa4d113ede46f8c107de6f604 (patch)
treeabe961b734c865ce3965f45585528c1ff39b94bd /build
parentf94c7b2c10d11d343c464be707e12c5754728b06 (diff)
Rewrote host environment targets to work out of the box
Diffstat (limited to 'build')
-rw-r--r--build/config.mk1
-rwxr-xr-xbuild/hostenv.sh6
2 files changed, 7 insertions, 0 deletions
diff --git a/build/config.mk b/build/config.mk
index 3cf13201f..5a8f22f89 100644
--- a/build/config.mk
+++ b/build/config.mk
@@ -1,5 +1,6 @@
LUAC = luac
LUAC_OPTIONS = -s
+LUA_TARGET = source
LUA_MODULEDIR = /usr/lib/lua
LUA_LIBRARYDIR = /usr/lib/lua
diff --git a/build/hostenv.sh b/build/hostenv.sh
new file mode 100755
index 000000000..ee906b001
--- /dev/null
+++ b/build/hostenv.sh
@@ -0,0 +1,6 @@
+#!/bin/sh
+export LD_LIBRARY_PATH="$1/usr/lib:$LD_LIBRARY_PATH"
+export PATH="$1/bin:$1/usr/bin:$PATH"
+export LUA_PATH="$1/$2/?.lua;$1/$2/?/init.lua;;"
+export LUA_CPATH="$1/$3/?.so;;"
+$4