summaryrefslogtreecommitdiffhomepage
path: root/build
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-06-09 07:56:20 +0000
committerSteven Barth <steven@midlink.org>2008-06-09 07:56:20 +0000
commit64806f32bea453b9a6fc5c4cf4c4b751a749e369 (patch)
treefa8916e368bebfdbb07451928d8aa119214945fd /build
parent004213483340028437736f5810bd1c2274b7b72c (diff)
* Made Makefiles attribute aware
Diffstat (limited to 'build')
-rw-r--r--build/module.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/build/module.mk b/build/module.mk
index 228860838..7fe96cac5 100644
--- a/build/module.mk
+++ b/build/module.mk
@@ -13,8 +13,8 @@ clean: luaclean
luasource:
mkdir -p dist$(LUCI_INSTALLDIR)
- cp root/* dist -R 2>/dev/null || true
- cp luasrc/* dist$(LUCI_INSTALLDIR) -R 2>/dev/null || true
+ cp -a root/* dist -R 2>/dev/null || true
+ cp -a luasrc/* dist$(LUCI_INSTALLDIR) -R 2>/dev/null || true
for i in $$(find dist -name .svn); do rm $$i -rf; done
luacompile: luasource