summaryrefslogtreecommitdiffhomepage
path: root/build/module.mk
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-05-27 12:13:19 +0000
committerSteven Barth <steven@midlink.org>2008-05-27 12:13:19 +0000
commit5df565faba5eb0c26a7ce0e2d6e9092bf71cb1e8 (patch)
treec2c69775ea80f868f90bbd77db2e928e3f34a506 /build/module.mk
parent20b14ac443e6c062bc624f38d984cc920f05b30d (diff)
add some indirection around make targets of module.mk, so you can combine it more easily with other build instructions
Diffstat (limited to 'build/module.mk')
-rw-r--r--build/module.mk14
1 files changed, 9 insertions, 5 deletions
diff --git a/build/module.mk b/build/module.mk
index a0bd2935c..8932f5761 100644
--- a/build/module.mk
+++ b/build/module.mk
@@ -1,15 +1,19 @@
-.PHONY: all compile source clean
+.PHONY: all compile compile-module source source-module clean clean-module
all: compile
+compile: compile-module
+clean: clean-module
+source: source-module
-source:
+source-module:
mkdir -p dist$(LUCI_INSTALLDIR)
cp root/* dist -R 2>/dev/null || true
cp src/* dist$(LUCI_INSTALLDIR) -R 2>/dev/null || true
for i in $$(find dist -name .svn); do rm $$i -rf; done
-compile: source
+compile-module: source-module
for i in $$(find dist -name *.lua -not -name debug.lua); do $(LUAC) $(LUAC_OPTIONS) -o $$i $$i; done
-
-clean:
+
+clean-module:
rm -rf dist
+