summaryrefslogtreecommitdiffhomepage
path: root/build/module.mk
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-06-14 14:12:12 +0000
committerSteven Barth <steven@midlink.org>2008-06-14 14:12:12 +0000
commit855b7582d3576f45693e3a48fdb253c813cf4dce (patch)
treeb912f63dc43f3b696385083542c801dba8c53976 /build/module.mk
parent50fd29841540bb8b1735291b72853454679e9e62 (diff)
* Rewrote Luci to be coroutine-safe allowing the use of non-forking webservers
* Setting base version to 0.7
Diffstat (limited to 'build/module.mk')
-rw-r--r--build/module.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/build/module.mk b/build/module.mk
index 7fe96cac5..4ef3668c8 100644
--- a/build/module.mk
+++ b/build/module.mk
@@ -12,9 +12,11 @@ compile:
clean: luaclean
luasource:
- mkdir -p dist$(LUCI_INSTALLDIR)
+ mkdir -p dist$(LUA_MODULEDIR)
+ mkdir -p dist$(LUCI_MODULEDIR)
cp -a root/* dist -R 2>/dev/null || true
- cp -a luasrc/* dist$(LUCI_INSTALLDIR) -R 2>/dev/null || true
+ cp -a luasrc/* dist$(LUCI_MODULEDIR) -R 2>/dev/null || true
+ cp -a lua/* dist$(LUA_MODULEDIR) -R 2>/dev/null || true
for i in $$(find dist -name .svn); do rm $$i -rf; done
luacompile: luasource