summaryrefslogtreecommitdiffhomepage
path: root/build/module.mk
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-05-08 15:37:41 +0000
committerSteven Barth <steven@midlink.org>2008-05-08 15:37:41 +0000
commitaa9ccf77c6648515ba58c37b9345cdbd561028db (patch)
treeb0270202d47b6c5e179f8475302bb3ef0d1c9402 /build/module.mk
parenta3a51464fd8cffa6d18fa3f18be9c699901abd0d (diff)
* Mördercommit ;-)
* Major Repository Reorganisation * API 0.4 Softfreeze to come
Diffstat (limited to 'build/module.mk')
-rw-r--r--build/module.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/build/module.mk b/build/module.mk
new file mode 100644
index 000000000..286927436
--- /dev/null
+++ b/build/module.mk
@@ -0,0 +1,15 @@
+.PHONY: all compile source clean
+
+all: compile
+
+source:
+ mkdir -p dist$(LUCI_INSTALLDIR)
+ cp root dist -R
+ cp src dist$(LUCI_INSTALLDIR) -R
+ for i in $$(find dist -name .svn); do rm $$i -rf; done
+
+compile: source
+ for i in $$(find dist -name *.lua); do $(LUAC) $(LUAC_OPTIONS) -o $$i $$i; done
+
+clean:
+ rm dist -rf \ No newline at end of file