summaryrefslogtreecommitdiffhomepage
path: root/build/module.mk
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-05-08 16:37:47 +0000
committerSteven Barth <steven@midlink.org>2008-05-08 16:37:47 +0000
commit6ae8e58510144112ab85e2d4984d58d37621c072 (patch)
tree57de72bfea91fc5d3edfc3b4492e59c21affb3cf /build/module.mk
parent58431689ecf8d3389a4600a1482fa8fcae3e95d7 (diff)
* Fix builds
Diffstat (limited to 'build/module.mk')
-rw-r--r--build/module.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/build/module.mk b/build/module.mk
index 45732a434..3db3cc3b7 100644
--- a/build/module.mk
+++ b/build/module.mk
@@ -4,8 +4,8 @@ all: compile
source:
mkdir -p dist$(LUCI_INSTALLDIR)
- cp root/* dist -R
- cp src/* dist$(LUCI_INSTALLDIR) -R
+ [ -d root ] && cp root/* dist -R
+ [ -d src ] && cp src/* dist$(LUCI_INSTALLDIR) -R
for i in $$(find dist -name .svn); do rm $$i -rf; done
compile: source