summaryrefslogtreecommitdiffhomepage
path: root/build/gccconfig.mk
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-06-03 16:33:34 +0000
committerSteven Barth <steven@midlink.org>2008-06-03 16:33:34 +0000
commita042407e94858610979446783be796ece5211cc7 (patch)
tree90adc16f41d466e2ac885e553dd10cb77bbd027e /build/gccconfig.mk
parent11a4ce396cd94fae3ebd8f386f28b5968464ae42 (diff)
Revert "* Don't override environment variables in Makefile"
This reverts commit e60afb9e0d2b1f791399f91c5de626fe215d1d88.
Diffstat (limited to 'build/gccconfig.mk')
-rw-r--r--build/gccconfig.mk30
1 files changed, 15 insertions, 15 deletions
diff --git a/build/gccconfig.mk b/build/gccconfig.mk
index 77bcf3674..0e4de2795 100644
--- a/build/gccconfig.mk
+++ b/build/gccconfig.mk
@@ -1,22 +1,22 @@
OS ?= $(shell uname)
-LUA_SHLIBS ?= $(shell pkg-config --silence-errors --libs lua5.1)
-LUA_LIBS ?= $(if $(LUA_SHLIBS),$(LUA_SHLIBS),$(firstword $(wildcard /usr/lib/liblua.a /usr/local/lib/liblua.a /opt/local/lib/liblua.a)))
-LUA_CFLAGS ?= $(shell pkg-config --silence-errors --cflags lua5.1)
+LUA_SHLIBS = $(shell pkg-config --silence-errors --libs lua5.1)
+LUA_LIBS = $(if $(LUA_SHLIBS),$(LUA_SHLIBS),$(firstword $(wildcard /usr/lib/liblua.a /usr/local/lib/liblua.a /opt/local/lib/liblua.a)))
+LUA_CFLAGS = $(shell pkg-config --silence-errors --cflags lua5.1)
-CC ?= gcc
-AR ?= ar
-RANLIB ?= ranlib
-CFLAGS ?= -O2
-FPIC ?= -fPIC
-EXTRA_CFLAGS ?= --std=gnu99
-WFLAGS ?= -Wall -Werror -pedantic
-CPPFLAGS ?=
-COMPILE ?= $(CC) $(CPPFLAGS) $(CFLAGS) $(EXTRA_CFLAGS) $(WFLAGS)
+CC = gcc
+AR = ar
+RANLIB = ranlib
+CFLAGS = -O2
+FPIC = -fPIC
+EXTRA_CFLAGS = --std=gnu99
+WFLAGS = -Wall -Werror -pedantic
+CPPFLAGS =
+COMPILE = $(CC) $(CPPFLAGS) $(CFLAGS) $(EXTRA_CFLAGS) $(WFLAGS)
ifeq ($(OS),Darwin)
- SHLIB_FLAGS ?= -bundle -undefined dynamic_lookup
+ SHLIB_FLAGS = -bundle -undefined dynamic_lookup
else
- SHLIB_FLAGS ?= -shared
+ SHLIB_FLAGS = -shared
endif
-LINK ?= $(CC)
+LINK = $(CC)