summaryrefslogtreecommitdiffhomepage
path: root/build/gccconfig.mk
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-05-28 19:37:43 +0000
committerSteven Barth <steven@midlink.org>2008-05-28 19:37:43 +0000
commit4e53d007bf30dddad1a2e1b44aa55d3ca8671ae4 (patch)
tree69e5a17bb861283f1333f3304b1e8dca16ef3955 /build/gccconfig.mk
parent38844ccb3107cd84488ae1cd67fec8e7de833eb4 (diff)
* Reworked Makefiles
* Introduced following targets: build: gccbuild luabuild gccbuild: compile luabuild: luasource||luacompile * Removed requirement for lua-headers respecting lua-only builds * Split compile part of OpenWRT Makefile
Diffstat (limited to 'build/gccconfig.mk')
-rw-r--r--build/gccconfig.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/build/gccconfig.mk b/build/gccconfig.mk
new file mode 100644
index 000000000..0e4de2795
--- /dev/null
+++ b/build/gccconfig.mk
@@ -0,0 +1,22 @@
+OS ?= $(shell uname)
+
+LUA_SHLIBS = $(shell pkg-config --silence-errors --libs lua5.1)
+LUA_LIBS = $(if $(LUA_SHLIBS),$(LUA_SHLIBS),$(firstword $(wildcard /usr/lib/liblua.a /usr/local/lib/liblua.a /opt/local/lib/liblua.a)))
+LUA_CFLAGS = $(shell pkg-config --silence-errors --cflags lua5.1)
+
+CC = gcc
+AR = ar
+RANLIB = ranlib
+CFLAGS = -O2
+FPIC = -fPIC
+EXTRA_CFLAGS = --std=gnu99
+WFLAGS = -Wall -Werror -pedantic
+CPPFLAGS =
+COMPILE = $(CC) $(CPPFLAGS) $(CFLAGS) $(EXTRA_CFLAGS) $(WFLAGS)
+ifeq ($(OS),Darwin)
+ SHLIB_FLAGS = -bundle -undefined dynamic_lookup
+else
+ SHLIB_FLAGS = -shared
+endif
+LINK = $(CC)
+