summaryrefslogtreecommitdiffhomepage
path: root/applications
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2016-06-04 07:41:10 +0200
committerMathias Kresin <dev@kresin.me>2016-06-12 12:41:17 +0200
commit59d391b5bdf86e889a188307adc6e49397a5e9b0 (patch)
tree6ec7dc4aee81cdf58065889766e7575afa227d2b /applications
parentd014234195f1bf3315e18a3fca5b933ba38f8460 (diff)
luci-app-ddns: pass the is_glue option value to the helper
Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'applications')
-rw-r--r--applications/luci-app-ddns/Makefile2
-rwxr-xr-xapplications/luci-app-ddns/luasrc/controller/ddns.lua4
2 files changed, 4 insertions, 2 deletions
diff --git a/applications/luci-app-ddns/Makefile b/applications/luci-app-ddns/Makefile
index 009c0b90b..7a09af07f 100644
--- a/applications/luci-app-ddns/Makefile
+++ b/applications/luci-app-ddns/Makefile
@@ -10,7 +10,7 @@ PKG_NAME:=luci-app-ddns
# Version == major.minor.patch
# increase on new functionality (minor) or patches (patch)
-PKG_VERSION:=2.4.4
+PKG_VERSION:=2.4.5
# Release == build
# increase on changes of translation files
diff --git a/applications/luci-app-ddns/luasrc/controller/ddns.lua b/applications/luci-app-ddns/luasrc/controller/ddns.lua
index 6d7594014..d6ccf9cd4 100755
--- a/applications/luci-app-ddns/luasrc/controller/ddns.lua
+++ b/applications/luci-app-ddns/luasrc/controller/ddns.lua
@@ -190,9 +190,11 @@ local function _get_status()
local dnsserver = s["dns_server"] or ""
local force_ipversion = tonumber(s["force_ipversion"] or 0)
local force_dnstcp = tonumber(s["force_dnstcp"] or 0)
+ local is_glue = tonumber(s["is_glue"] or 0)
local command = [[/usr/lib/ddns/dynamic_dns_lucihelper.sh]]
command = command .. [[ get_registered_ip ]] .. lookup_host .. [[ ]] .. use_ipv6 ..
- [[ ]] .. force_ipversion .. [[ ]] .. force_dnstcp .. [[ ]] .. dnsserver
+ [[ ]] .. force_ipversion .. [[ ]] .. force_dnstcp .. [[ ]] .. dnsserver ..
+ [[ ]] .. is_glue
local reg_ip = SYS.exec(command)
if reg_ip == "" then
reg_ip = "_nodata_"