summaryrefslogtreecommitdiffhomepage
path: root/applications
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-05-22 14:04:03 +0000
committerSteven Barth <steven@midlink.org>2008-05-22 14:04:03 +0000
commit6604399aa8f35d33c53a5e5a1fea765f401aef5e (patch)
treeed818d630634a98a8996a1ba6d10e63bbea17c39 /applications
parentf738eb786e3d30028310c7bcc447e7e7b63767e0 (diff)
Merge branch 'menu'
Diffstat (limited to 'applications')
-rw-r--r--applications/community-halle/Makefile2
-rw-r--r--applications/community-halle/root/etc/uci-defaults/ffluci-community-halle16
-rw-r--r--applications/luci-fw/src/controller/luci_fw/luci_fw.lua18
-rw-r--r--applications/luci-fw/src/model/cbi/luci_fw/firewall.lua (renamed from applications/luci-fw/src/model/cbi/admin_network/firewall.lua)0
-rw-r--r--applications/luci-fw/src/model/cbi/luci_fw/portfw.lua (renamed from applications/luci-fw/src/model/cbi/admin_network/portfw.lua)0
-rw-r--r--applications/luci-fw/src/model/cbi/luci_fw/routing.lua (renamed from applications/luci-fw/src/model/cbi/admin_network/routing.lua)0
-rw-r--r--applications/luci-fw/src/model/menu/50luci-fw.lua4
-rw-r--r--applications/luci-splash/src/controller/splash/splash.lua13
-rw-r--r--applications/luci-splash/src/model/cbi/splash/splash.lua (renamed from applications/luci-splash/src/model/cbi/admin_services/splash.lua)0
-rw-r--r--applications/luci-splash/src/model/menu/50luci-splash.lua2
-rwxr-xr-xapplications/sgi-haserl/root/www/cgi-bin/ffluci5
-rw-r--r--applications/sgi-webuci/root/lib/webuci/main.lua6
12 files changed, 52 insertions, 14 deletions
diff --git a/applications/community-halle/Makefile b/applications/community-halle/Makefile
new file mode 100644
index 000000000..81a96f6a8
--- /dev/null
+++ b/applications/community-halle/Makefile
@@ -0,0 +1,2 @@
+include ../../build/config.mk
+include ../../build/module.mk \ No newline at end of file
diff --git a/applications/community-halle/root/etc/uci-defaults/ffluci-community-halle b/applications/community-halle/root/etc/uci-defaults/ffluci-community-halle
new file mode 100644
index 000000000..8e4286a57
--- /dev/null
+++ b/applications/community-halle/root/etc/uci-defaults/ffluci-community-halle
@@ -0,0 +1,16 @@
+#!/bin/sh
+uci batch <<-EOF
+ set freifunk.community.name='Freifunk Halle'
+ set freifunk.community.homepage=http://halle.freifunk.net
+ set freifunk.community.essid=halle.freifunk.net
+ set freifunk.community.bssid=02:CA:FF:EE:BA:BE
+ set freifunk.community.realm=pool.freifunk-halle.net
+ set freifunk.community.channel=1
+ set freifunk.community.net=104.0.0.0
+ set freifunk.community.mask=255.0.0.0
+ set freifunk.community.dhcp=10.0.0.0
+ set freifunk.community.dhcpmask=255.255.255.0
+ set freifunk.community.dns='88.198.178.18 141.54.1.1 212.204.49.83 208.67.220.220 208.67.222.222'
+ commit freifunk
+EOF
+
diff --git a/applications/luci-fw/src/controller/luci_fw/luci_fw.lua b/applications/luci-fw/src/controller/luci_fw/luci_fw.lua
new file mode 100644
index 000000000..864455ca8
--- /dev/null
+++ b/applications/luci-fw/src/controller/luci_fw/luci_fw.lua
@@ -0,0 +1,18 @@
+module("ffluci.controller.luci_fw.luci_fw", package.seeall)
+
+function index()
+ local page = node("admin", "network", "portfw")
+ page.target = cbi("luci_fw/portfw")
+ page.title = "Portweiterleitung"
+ page.order = 70
+
+ local page = node("admin", "network", "routing")
+ page.target = cbi("luci_fw/routing")
+ page.title = "Routing"
+ page.order = 72
+
+ local page = node("admin", "network", "firewall")
+ page.target = cbi("luci_fw/firewall")
+ page.title = "Firewall"
+ page.order = 74
+end \ No newline at end of file
diff --git a/applications/luci-fw/src/model/cbi/admin_network/firewall.lua b/applications/luci-fw/src/model/cbi/luci_fw/firewall.lua
index 7c89d07c5..7c89d07c5 100644
--- a/applications/luci-fw/src/model/cbi/admin_network/firewall.lua
+++ b/applications/luci-fw/src/model/cbi/luci_fw/firewall.lua
diff --git a/applications/luci-fw/src/model/cbi/admin_network/portfw.lua b/applications/luci-fw/src/model/cbi/luci_fw/portfw.lua
index 90ebb4c24..90ebb4c24 100644
--- a/applications/luci-fw/src/model/cbi/admin_network/portfw.lua
+++ b/applications/luci-fw/src/model/cbi/luci_fw/portfw.lua
diff --git a/applications/luci-fw/src/model/cbi/admin_network/routing.lua b/applications/luci-fw/src/model/cbi/luci_fw/routing.lua
index 5805b1d3f..5805b1d3f 100644
--- a/applications/luci-fw/src/model/cbi/admin_network/routing.lua
+++ b/applications/luci-fw/src/model/cbi/luci_fw/routing.lua
diff --git a/applications/luci-fw/src/model/menu/50luci-fw.lua b/applications/luci-fw/src/model/menu/50luci-fw.lua
deleted file mode 100644
index b7543b062..000000000
--- a/applications/luci-fw/src/model/menu/50luci-fw.lua
+++ /dev/null
@@ -1,4 +0,0 @@
-sel("admin", "network")
-act("portfw", "Portweiterleitung")
-act("routing", "Routing")
-act("firewall", "Firewall") \ No newline at end of file
diff --git a/applications/luci-splash/src/controller/splash/splash.lua b/applications/luci-splash/src/controller/splash/splash.lua
index 62088be52..7d837cd34 100644
--- a/applications/luci-splash/src/controller/splash/splash.lua
+++ b/applications/luci-splash/src/controller/splash/splash.lua
@@ -1,5 +1,16 @@
module("ffluci.controller.splash.splash", package.seeall)
+function index()
+ local page = node("admin", "services", "splash")
+ page.target = cbi("splash/splash")
+ page.title = "Client-Splash"
+
+ node("splash", "splash", "activate").target = action_activate
+ node("splash", "splash", "allowed").target = action_allowed
+ node("splash", "splash", "unknown").target = action_unknown
+ node("splash", "splash", "splash").target = template("splash_splash/splash")
+end
+
function action_activate()
local mac = ffluci.sys.net.ip4mac(ffluci.http.env.REMOTE_ADDR)
if mac and ffluci.http.formvalue("accept") then
@@ -10,7 +21,7 @@ function action_activate()
end
end
-function action_accepted()
+function action_allowed()
ffluci.http.redirect(ffluci.dispatcher.build_url())
end
diff --git a/applications/luci-splash/src/model/cbi/admin_services/splash.lua b/applications/luci-splash/src/model/cbi/splash/splash.lua
index fe4d2c3ee..fe4d2c3ee 100644
--- a/applications/luci-splash/src/model/cbi/admin_services/splash.lua
+++ b/applications/luci-splash/src/model/cbi/splash/splash.lua
diff --git a/applications/luci-splash/src/model/menu/50luci-splash.lua b/applications/luci-splash/src/model/menu/50luci-splash.lua
deleted file mode 100644
index 99f7caa52..000000000
--- a/applications/luci-splash/src/model/menu/50luci-splash.lua
+++ /dev/null
@@ -1,2 +0,0 @@
-sel("admin", "services")
-act("splash", "Client-Splash") \ No newline at end of file
diff --git a/applications/sgi-haserl/root/www/cgi-bin/ffluci b/applications/sgi-haserl/root/www/cgi-bin/ffluci
index 183a6ad41..f3d85df64 100755
--- a/applications/sgi-haserl/root/www/cgi-bin/ffluci
+++ b/applications/sgi-haserl/root/www/cgi-bin/ffluci
@@ -1,4 +1,3 @@
#!/usr/bin/haserl --shell=luac
-package.path = "/usr/lib/lua/?.lua;/usr/lib/lua/?/init.lua;" .. package.path
-package.cpath = "/usr/lib/lua/?.so;" .. package.cpath
-require("ffluci.dispatcher").httpdispatch() \ No newline at end of file
+require("ffluci.dispatcher").createindex()
+ffluci.dispatcher.httpdispatch() \ No newline at end of file
diff --git a/applications/sgi-webuci/root/lib/webuci/main.lua b/applications/sgi-webuci/root/lib/webuci/main.lua
index 50ac8184b..f21934e0a 100644
--- a/applications/sgi-webuci/root/lib/webuci/main.lua
+++ b/applications/sgi-webuci/root/lib/webuci/main.lua
@@ -1,11 +1,9 @@
-package.path = "/usr/lib/lua/?.lua;/usr/lib/lua/?/init.lua;" .. package.path
-package.cpath = "/usr/lib/lua/?.so;" .. package.cpath
module("webuci", package.seeall)
function prepare_req(uri)
env = {}
env.REQUEST_URI = uri
- require("ffluci.menu").get()
+ require("ffluci.dispatcher").createindex()
end
function init_req(context)
@@ -19,5 +17,5 @@ function init_req(context)
end
function handle_req(context)
- require("ffluci.dispatcher").httpdispatch()
+ ffluci.dispatcher.httpdispatch()
end \ No newline at end of file