summaryrefslogtreecommitdiffhomepage
path: root/applications
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-06-08 08:14:31 +0000
committerSteven Barth <steven@midlink.org>2008-06-08 08:14:31 +0000
commit7d03f8ea8a5edf72b708a8a4f45346048274fae6 (patch)
tree5e043f366b4db2b02d3389b09e5699c485c57bc8 /applications
parent09ecbe73ed51cdbbb204f323ad9207505680cd94 (diff)
* Core translation
* Added license headers * Splitted qos into separate application package
Diffstat (limited to 'applications')
-rw-r--r--applications/luci-olsr/luasrc/controller/olsr.lua4
-rw-r--r--applications/luci-qos/Makefile2
-rw-r--r--applications/luci-qos/luasrc/controller/qos.lua22
-rw-r--r--applications/luci-qos/luasrc/model/cbi/qos/qos.lua68
4 files changed, 96 insertions, 0 deletions
diff --git a/applications/luci-olsr/luasrc/controller/olsr.lua b/applications/luci-olsr/luasrc/controller/olsr.lua
index 24159b7cc..d795dc4ed 100644
--- a/applications/luci-olsr/luasrc/controller/olsr.lua
+++ b/applications/luci-olsr/luasrc/controller/olsr.lua
@@ -1,6 +1,10 @@
module("luci.controller.olsr", package.seeall)
function index()
+ if not luci.fs.isfile("/etc/config/olsr") then
+ return
+ end
+
local page = node("admin", "status", "olsr")
page.target = call("action_index")
page.title = "OLSR"
diff --git a/applications/luci-qos/Makefile b/applications/luci-qos/Makefile
new file mode 100644
index 000000000..81a96f6a8
--- /dev/null
+++ b/applications/luci-qos/Makefile
@@ -0,0 +1,2 @@
+include ../../build/config.mk
+include ../../build/module.mk \ No newline at end of file
diff --git a/applications/luci-qos/luasrc/controller/qos.lua b/applications/luci-qos/luasrc/controller/qos.lua
new file mode 100644
index 000000000..faddbace8
--- /dev/null
+++ b/applications/luci-qos/luasrc/controller/qos.lua
@@ -0,0 +1,22 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
+module("luci.controller.qos", package.seeall)
+
+function index()
+ if not luci.fs.isfile("/etc/config/qos") then
+ return
+ end
+
+ entry({"admin", "network", "qos"}, cbi("qos/qos"), "Quality of Service")
+end \ No newline at end of file
diff --git a/applications/luci-qos/luasrc/model/cbi/qos/qos.lua b/applications/luci-qos/luasrc/model/cbi/qos/qos.lua
new file mode 100644
index 000000000..2af820d6f
--- /dev/null
+++ b/applications/luci-qos/luasrc/model/cbi/qos/qos.lua
@@ -0,0 +1,68 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
+m = Map("qos", "Quality of Service", [[Mit Hilfe von QoS kann einzelnen Rechnern oder Netzwerkdiensten
+eine höhere oder niedrigere Priorität zugewiesen werden.]])
+
+s = m:section(TypedSection, "interface", "Schnittstellen")
+s.addremove = true
+
+s:option(Flag, "enabled", "aktiviert")
+
+c = s:option(ListValue, "classgroup", "Klassifizierung")
+c:value("Default", "standard")
+c.default = "Default"
+
+s:option(Flag, "overhead", "Overheadberechnung")
+
+s:option(Value, "download", "Downlink", "kb/s")
+
+s:option(Value, "upload", "Uplink", "kb/s")
+
+s = m:section(TypedSection, "classify", "Klassifizierung")
+
+s.anonymous = true
+s.addremove = true
+
+t = s:option(ListValue, "target", "Klasse")
+t:value("Priority")
+t:value("Express")
+t:value("Normal")
+t:value("Bulk")
+t.default = "Normal"
+
+s:option(Value, "srchost", "Quelladresse", "Quellhost / Quellnetz").optional = true
+s:option(Value, "dsthost", "Zieladresse", "Zielhost / Zielnetz").optional = true
+s:option(Value, "layer7", "Layer 7").optional = true
+
+p2p = s:option(ListValue, "ipp2p", "P2P")
+p2p:value("")
+p2p:value("all", "Alle")
+p2p:value("bit", "Bittorrent")
+p2p:value("dc", "DirectConnect")
+p2p:value("edk", "eDonkey")
+p2p:value("gnu", "Gnutella")
+p2p:value("kazaa", "Kazaa")
+p2p.optional = true
+
+p = s:option(ListValue, "proto", "Protokoll")
+p:value("")
+p:value("tcp", "TCP")
+p:value("udp", "UDP")
+p:value("icmp", "ICMP")
+p.optional = true
+
+s:option(Value, "ports", "Port").optional = true
+s:option(Value, "portrange", "Portbereich").optional = true
+
+return m \ No newline at end of file