summaryrefslogtreecommitdiffhomepage
path: root/applications
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2019-10-08 08:29:08 +0200
committerGitHub <noreply@github.com>2019-10-08 08:29:08 +0200
commite459683822925bcdeb552673a4811aa3b4322640 (patch)
tree461494c03aadd39bfe7a0c18e926121309a38e9f /applications
parent5ccbda54e810f51d7ab343815c6b80928eecfcbd (diff)
parent95cf84377450afa1a4b9951dd746b6bbae4e90af (diff)
Merge pull request #3134 from stangri/master-luci-app-https_dns_proxy
luci-app-https_dns_proxy: bugfix: proper formatting of dhcp server entries
Diffstat (limited to 'applications')
-rw-r--r--applications/luci-app-https_dns_proxy/Makefile2
-rw-r--r--applications/luci-app-https_dns_proxy/luasrc/model/cbi/https_dns_proxy.lua4
2 files changed, 3 insertions, 3 deletions
diff --git a/applications/luci-app-https_dns_proxy/Makefile b/applications/luci-app-https_dns_proxy/Makefile
index afc160723..7af2d1d10 100644
--- a/applications/luci-app-https_dns_proxy/Makefile
+++ b/applications/luci-app-https_dns_proxy/Makefile
@@ -10,7 +10,7 @@ LUCI_TITLE:=HTTPS DNS Proxy Web UI
LUCI_DESCRIPTION:=Provides Web UI for HTTPS DNS Proxy
LUCI_DEPENDS:=+luci-mod-admin-full +https_dns_proxy
LUCI_PKGARCH:=all
-PKG_RELEASE:=3
+PKG_RELEASE:=4
include ../../luci.mk
diff --git a/applications/luci-app-https_dns_proxy/luasrc/model/cbi/https_dns_proxy.lua b/applications/luci-app-https_dns_proxy/luasrc/model/cbi/https_dns_proxy.lua
index 03a3b4e08..2cc9f303c 100644
--- a/applications/luci-app-https_dns_proxy/luasrc/model/cbi/https_dns_proxy.lua
+++ b/applications/luci-app-https_dns_proxy/luasrc/model/cbi/https_dns_proxy.lua
@@ -75,8 +75,8 @@ prov.write = function(self, section, value)
if n == 0 then
uci:delete("dhcp", "@dnsmasq[0]", "server")
end
- uci_del_list("dhcp", "@dnsmasq[0]", "server", tostring(la_val) .. ":" .. tostring(lp_val))
- uci_add_list("dhcp", "@dnsmasq[0]", "server", tostring(la_val) .. ":" .. tostring(lp_val))
+ uci_del_list("dhcp", "@dnsmasq[0]", "server", tostring(la_val) .. "#" .. tostring(lp_val))
+ uci_add_list("dhcp", "@dnsmasq[0]", "server", tostring(la_val) .. "#" .. tostring(lp_val))
uci:save("dhcp")
end