summaryrefslogtreecommitdiffhomepage
path: root/applications
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2008-09-24 12:46:07 +0000
committerJo-Philipp Wich <jow@openwrt.org>2008-09-24 12:46:07 +0000
commit2ba7e61dce255419d33dcb1cb02ca5cf8e8655c1 (patch)
tree2c2a64b0a7ebdfc26fd5a40644527f2475d1a229 /applications
parent1a4869342a36012db9fb7b59262d75e6e63d34cd (diff)
* luci/applications: add ushare package
Diffstat (limited to 'applications')
-rw-r--r--applications/luci-ushare/Makefile2
-rw-r--r--applications/luci-ushare/ipkg/postinst4
-rw-r--r--applications/luci-ushare/luasrc/controller/ushare.lua28
-rw-r--r--applications/luci-ushare/luasrc/i18n/ushare.en.lua3
-rw-r--r--applications/luci-ushare/luasrc/model/cbi/ushare.lua38
-rw-r--r--applications/luci-ushare/root/etc/uci-defaults/luci-ushare7
6 files changed, 82 insertions, 0 deletions
diff --git a/applications/luci-ushare/Makefile b/applications/luci-ushare/Makefile
new file mode 100644
index 000000000..f7fac7740
--- /dev/null
+++ b/applications/luci-ushare/Makefile
@@ -0,0 +1,2 @@
+include ../../build/config.mk
+include ../../build/module.mk
diff --git a/applications/luci-ushare/ipkg/postinst b/applications/luci-ushare/ipkg/postinst
new file mode 100644
index 000000000..f3924893d
--- /dev/null
+++ b/applications/luci-ushare/ipkg/postinst
@@ -0,0 +1,4 @@
+#!/bin/sh
+[ -n "${IPKG_INSTROOT}" ] || {
+ ( . /etc/uci-defaults/luci-ushare ) && rm -f /etc/uci-defaults/luci-ushare
+}
diff --git a/applications/luci-ushare/luasrc/controller/ushare.lua b/applications/luci-ushare/luasrc/controller/ushare.lua
new file mode 100644
index 000000000..2fdea4e83
--- /dev/null
+++ b/applications/luci-ushare/luasrc/controller/ushare.lua
@@ -0,0 +1,28 @@
+--[[
+
+LuCI uShare
+(c) 2008 Yanira <forum-2008@email.de>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+
+]]--
+
+module("luci.controller.ushare", package.seeall)
+
+function index()
+ require("luci.i18n")
+ luci.i18n.loadc("ushare")
+ if not luci.fs.isfile("/etc/config/ushare") then
+ return
+ end
+
+ local page = entry({"admin", "services", "ushare"}, cbi("ushare"), luci.i18n.translate("ushare", "uShare"), 60)
+ page.i18n = "uvc_streamer"
+ page.dependent = true
+end
diff --git a/applications/luci-ushare/luasrc/i18n/ushare.en.lua b/applications/luci-ushare/luasrc/i18n/ushare.en.lua
new file mode 100644
index 000000000..2da960ff4
--- /dev/null
+++ b/applications/luci-ushare/luasrc/i18n/ushare.en.lua
@@ -0,0 +1,3 @@
+settings = 'Settings'
+ushare = 'uShare'
+ushare_desc = 'uShare'
diff --git a/applications/luci-ushare/luasrc/model/cbi/ushare.lua b/applications/luci-ushare/luasrc/model/cbi/ushare.lua
new file mode 100644
index 000000000..254ea2331
--- /dev/null
+++ b/applications/luci-ushare/luasrc/model/cbi/ushare.lua
@@ -0,0 +1,38 @@
+--[[
+
+LuCI uShare
+(c) 2008 Yanira <forum-2008@email.de>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+
+]]--
+
+m = Map("ushare", translate("ushare"),
+ translatef("ushare_desc"))
+
+s = m:section(TypedSection, "ushare", translate("settings"))
+s.addremove = false
+s.anonymous = true
+
+s:option(Flag, "enabled", translate("enabled", "Enable"))
+
+s:option(Value, "username", translate("username"))
+
+s:option(Value, "servername", translate("servername"))
+
+dif = s:option( Value, "interface", translate("interface"))
+for _, nif in ipairs(luci.sys.net.devices()) do
+ if nif ~= "lo" then dif:value(nif) end
+end
+
+s:option(Value, "content_directories", translate("content_directories"))
+
+s:option(Value, "options", translate("options"))
+
+return m
diff --git a/applications/luci-ushare/root/etc/uci-defaults/luci-ushare b/applications/luci-ushare/root/etc/uci-defaults/luci-ushare
new file mode 100644
index 000000000..262420eba
--- /dev/null
+++ b/applications/luci-ushare/root/etc/uci-defaults/luci-ushare
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+uci batch <<-EOF
+ add ucitrack ushare
+ set ucitrack.@ushare[-1].init=ushare
+ commit ucitrack
+EOF