summaryrefslogtreecommitdiffhomepage
path: root/applications/sgi-webuci
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-05-27 09:33:52 +0000
committerSteven Barth <steven@midlink.org>2008-05-27 09:33:52 +0000
commit93ff578ac8f0cd4772285a6ea983cf02cc9be620 (patch)
treef766e8c0be94fe317673cefee879fbf73bc8cbd9 /applications/sgi-webuci
parent30c8b259e1b7012f7c16c1ee5aeb1997e44dcbdc (diff)
* 3rd Package reorgnaisation
* Moved core, web, cbi to libs * Refactored OpenWRT Makefile to separate Libraries, Webinterface Components, Freifunk packages
Diffstat (limited to 'applications/sgi-webuci')
-rw-r--r--applications/sgi-webuci/Makefile2
-rw-r--r--applications/sgi-webuci/root/lib/webuci/main.lua20
-rw-r--r--applications/sgi-webuci/src/sgi/webuci.lua100
3 files changed, 0 insertions, 122 deletions
diff --git a/applications/sgi-webuci/Makefile b/applications/sgi-webuci/Makefile
deleted file mode 100644
index 81a96f6a8..000000000
--- a/applications/sgi-webuci/Makefile
+++ /dev/null
@@ -1,2 +0,0 @@
-include ../../build/config.mk
-include ../../build/module.mk \ No newline at end of file
diff --git a/applications/sgi-webuci/root/lib/webuci/main.lua b/applications/sgi-webuci/root/lib/webuci/main.lua
deleted file mode 100644
index cb2730d14..000000000
--- a/applications/sgi-webuci/root/lib/webuci/main.lua
+++ /dev/null
@@ -1,20 +0,0 @@
-module("webuci", package.seeall)
-
-function prepare_req(uri)
- require("luci.dispatcher").createindex()
- env = {}
- env.REQUEST_URI = uri
-end
-
-function handle_req(context)
- env.SERVER_PROTOCOL = context.server_proto
- env.REMOTE_ADDR = context.remote_addr
- env.REQUEST_METHOD = context.request_method
- env.PATH_INFO = context.uri
- env.REMOTE_PORT = context.remote_port
- env.SERVER_ADDR = context.server_addr
- env.SCRIPT_NAME = env.REQUEST_URI:sub(1, #env.REQUEST_URI - #env.PATH_INFO)
-
- luci.sgi.webuci.initenv(env)
- luci.dispatcher.httpdispatch()
-end \ No newline at end of file
diff --git a/applications/sgi-webuci/src/sgi/webuci.lua b/applications/sgi-webuci/src/sgi/webuci.lua
deleted file mode 100644
index 498bca921..000000000
--- a/applications/sgi-webuci/src/sgi/webuci.lua
+++ /dev/null
@@ -1,100 +0,0 @@
---[[
-LuCI - SGI-Module for Haserl
-
-Description:
-Server Gateway Interface for Haserl
-
-FileId:
-$Id: webuci.lua 2027 2008-05-07 21:16:35Z Cyrus $
-
-License:
-Copyright 2008 Steven Barth <steven@midlink.org>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-Unless required by applicable law or agreed to in writing, software
-distributed under the License is distributed on an "AS IS" BASIS,
-WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-See the License for the specific language governing permissions and
-limitations under the License.
-
-]]--
-module("luci.sgi.webuci", package.seeall)
-
-local status_set = false
-
--- Initialize the environment
-function initenv(env)
- luci.http.env = env
-end
-
--- Returns the main dispatcher URL
-function luci.http.dispatcher()
- return luci.http.env.SCRIPT_NAME or ""
-end
-
--- Returns the upload dispatcher URL
-function luci.http.dispatcher_upload()
- -- To be implemented
-end
-
--- Returns a table of all COOKIE, GET and POST Parameters
-function luci.http.formvalues()
- return webuci.vars
-end
-
--- Gets form value from key
-function luci.http.formvalue(key, default)
- return luci.http.formvalues()[key] or default
-end
-
--- Gets a table of values with a certain prefix
-function luci.http.formvaluetable(prefix)
- local vals = {}
- prefix = prefix and prefix .. "." or "."
-
- for k, v in pairs(luci.http.formvalues()) do
- if k:find(prefix, 1, true) == 1 then
- vals[k:sub(#prefix + 1)] = v
- end
- end
-
- return vals
-end
-
--- Sends a custom HTTP-Header
-function luci.http.header(key, value)
- print(key .. ": " .. value)
-end
-
--- Set Content-Type
-function luci.http.prepare_content(type)
- if not status_set then
- luci.http.status(200, "OK")
- end
-
- print("Content-Type: "..type.."\n")
-end
-
--- Asks the browser to redirect to "url"
-function luci.http.redirect(url)
- luci.http.status(302, "Found")
- luci.http.header("Location", url)
- print()
-end
-
--- Returns the path of an uploaded file
--- WARNING! File uploads can be easily spoofed! Do additional sanity checks!
-function luci.http.upload(name)
- -- To be implemented
-end
-
--- Sets HTTP-Status-Header
-function luci.http.status(code, message)
- print(luci.http.env.SERVER_PROTOCOL .. " " .. tostring(code) .. " " .. message)
- status_set = true
-end