summaryrefslogtreecommitdiffhomepage
path: root/applications/sgi-haserl
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-05-27 09:33:52 +0000
committerSteven Barth <steven@midlink.org>2008-05-27 09:33:52 +0000
commit93ff578ac8f0cd4772285a6ea983cf02cc9be620 (patch)
treef766e8c0be94fe317673cefee879fbf73bc8cbd9 /applications/sgi-haserl
parent30c8b259e1b7012f7c16c1ee5aeb1997e44dcbdc (diff)
* 3rd Package reorgnaisation
* Moved core, web, cbi to libs * Refactored OpenWRT Makefile to separate Libraries, Webinterface Components, Freifunk packages
Diffstat (limited to 'applications/sgi-haserl')
-rw-r--r--applications/sgi-haserl/Makefile2
-rwxr-xr-xapplications/sgi-haserl/root/www/cgi-bin/index.cgi3
-rwxr-xr-xapplications/sgi-haserl/root/www/cgi-bin/luci2
-rwxr-xr-xapplications/sgi-haserl/root/www/cgi-bin/luci-upload4
-rw-r--r--applications/sgi-haserl/root/www/index.html10
-rw-r--r--applications/sgi-haserl/src/sgi/haserl.lua97
6 files changed, 0 insertions, 118 deletions
diff --git a/applications/sgi-haserl/Makefile b/applications/sgi-haserl/Makefile
deleted file mode 100644
index 81a96f6a83..0000000000
--- a/applications/sgi-haserl/Makefile
+++ /dev/null
@@ -1,2 +0,0 @@
-include ../../build/config.mk
-include ../../build/module.mk \ No newline at end of file
diff --git a/applications/sgi-haserl/root/www/cgi-bin/index.cgi b/applications/sgi-haserl/root/www/cgi-bin/index.cgi
deleted file mode 100755
index aae8591c6a..0000000000
--- a/applications/sgi-haserl/root/www/cgi-bin/index.cgi
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/usr/bin/haserl --shell=luac
-print("Status: 302 Found")
-print("Location: luci\n")
diff --git a/applications/sgi-haserl/root/www/cgi-bin/luci b/applications/sgi-haserl/root/www/cgi-bin/luci
deleted file mode 100755
index 13fec754e3..0000000000
--- a/applications/sgi-haserl/root/www/cgi-bin/luci
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/usr/bin/haserl --shell=luac
-require("luci.dispatcher").httpdispatch() \ No newline at end of file
diff --git a/applications/sgi-haserl/root/www/cgi-bin/luci-upload b/applications/sgi-haserl/root/www/cgi-bin/luci-upload
deleted file mode 100755
index 371967ce98..0000000000
--- a/applications/sgi-haserl/root/www/cgi-bin/luci-upload
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/usr/bin/haserl --shell=luac --upload-limit=16384
--- This is a bit hacky: remove -upload from SCRIPT_NAME
-ENV.SCRIPT_NAME = ENV.SCRIPT_NAME:sub(1, #ENV.SCRIPT_NAME - 7)
-dofile("luci") \ No newline at end of file
diff --git a/applications/sgi-haserl/root/www/index.html b/applications/sgi-haserl/root/www/index.html
deleted file mode 100644
index 39ba558dfb..0000000000
--- a/applications/sgi-haserl/root/www/index.html
+++ /dev/null
@@ -1,10 +0,0 @@
-<?xml version="1.0" encoding="utf-8"?>
-<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
-<html xmlns="http://www.w3.org/1999/xhtml">
-<head>
-<meta http-equiv="refresh" content="0; URL=/cgi-bin/index.cgi" />
-</head>
-<body style="background-color: black">
-<a style="color: white; text-decoration: none" href="/cgi-bin/index.cgi">LuCI - Lua Configuration Interface</a>
-</body>
-</html> \ No newline at end of file
diff --git a/applications/sgi-haserl/src/sgi/haserl.lua b/applications/sgi-haserl/src/sgi/haserl.lua
deleted file mode 100644
index f3994b5c8c..0000000000
--- a/applications/sgi-haserl/src/sgi/haserl.lua
+++ /dev/null
@@ -1,97 +0,0 @@
---[[
-LuCI - SGI-Module for Haserl
-
-Description:
-Server Gateway Interface for Haserl
-
-FileId:
-$Id: haserl.lua 2027 2008-05-07 21:16:35Z Cyrus $
-
-License:
-Copyright 2008 Steven Barth <steven@midlink.org>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-Unless required by applicable law or agreed to in writing, software
-distributed under the License is distributed on an "AS IS" BASIS,
-WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-See the License for the specific language governing permissions and
-limitations under the License.
-
-]]--
-module("luci.sgi.haserl", package.seeall)
-require("luci.fs")
-
--- Environment Table
-luci.http.env = ENV
-
--- Returns the main dispatcher URL
-function luci.http.dispatcher()
- return luci.http.env.SCRIPT_NAME or ""
-end
-
--- Returns the upload dispatcher URL
-function luci.http.dispatcher_upload()
- return luci.http.dispatcher() .. "-upload"
-end
-
--- Returns a table of all COOKIE, GET and POST Parameters
-function luci.http.formvalues()
- return FORM
-end
-
--- Gets form value from key
-function luci.http.formvalue(key, default)
- local c = luci.http.formvalues()
-
- for match in key:gmatch("[%w-_]+") do
- c = c[match]
- if c == nil then
- return default
- end
- end
-
- return c
-end
-
--- Gets a table of values with a certain prefix
-function luci.http.formvaluetable(prefix)
- return luci.http.formvalue(prefix, {})
-end
-
--- Sends a custom HTTP-Header
-function luci.http.header(key, value)
- print(key .. ": " .. value)
-end
-
--- Set Content-Type
-function luci.http.prepare_content(type)
- print("Content-Type: "..type.."\n")
-end
-
--- Asks the browser to redirect to "url"
-function luci.http.redirect(url)
- luci.http.status(302, "Found")
- luci.http.header("Location", url)
- print()
-end
-
--- Returns the path of an uploaded file
--- WARNING! File uploads can be easily spoofed! Do additional sanity checks!
-function luci.http.upload(name)
- local fpath = luci.http.formvalue(name)
- local fname = luci.http.formvalue(name .. "_name")
-
- if fpath and fname and luci.fs.isfile(fpath) then
- return fpath
- end
-end
-
--- Sets HTTP-Status-Header
-function luci.http.status(code, message)
- print("Status: " .. tostring(code) .. " " .. message)
-end