summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-watchcat
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-watchcat
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-watchcat')
-rw-r--r--applications/luci-watchcat/Makefile3
-rw-r--r--applications/luci-watchcat/ipkg/postinst7
-rw-r--r--applications/luci-watchcat/luasrc/controller/watchcat.lua22
-rw-r--r--applications/luci-watchcat/luasrc/model/cbi/watchcat/watchcat.lua64
-rw-r--r--applications/luci-watchcat/root/etc/uci-defaults/luci-watchcat10
5 files changed, 0 insertions, 106 deletions
diff --git a/applications/luci-watchcat/Makefile b/applications/luci-watchcat/Makefile
deleted file mode 100644
index 2cb156c0b..000000000
--- a/applications/luci-watchcat/Makefile
+++ /dev/null
@@ -1,3 +0,0 @@
-PO=watchcat
-include ../../build/config.mk
-include ../../build/module.mk
diff --git a/applications/luci-watchcat/ipkg/postinst b/applications/luci-watchcat/ipkg/postinst
deleted file mode 100644
index 99114604a..000000000
--- a/applications/luci-watchcat/ipkg/postinst
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-me="watchcat"
-[ -n "${IPKG_INSTROOT}" ] || {
- ( . /etc/uci-defaults/luci-$me ) && rm -f /etc/uci-defaults/luci-$me
- /etc/init.d/$me enabled || /etc/init.d/$me enable
- exit 0
-}
diff --git a/applications/luci-watchcat/luasrc/controller/watchcat.lua b/applications/luci-watchcat/luasrc/controller/watchcat.lua
deleted file mode 100644
index 5eba5cdeb..000000000
--- a/applications/luci-watchcat/luasrc/controller/watchcat.lua
+++ /dev/null
@@ -1,22 +0,0 @@
---[[
-LuCI - Lua Configuration Interface
-
-Copyright 2012 Christian Gagneraud <chris@techworks.ie>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-$Id$
-]]--
-
-module("luci.controller.watchcat", package.seeall)
-
-function index()
- if not nixio.fs.access("/etc/config/system") then
- return
- end
- entry({"admin", "services", "watchcat"}, cbi("watchcat/watchcat"), _("Watchcat"), 90)
-end
diff --git a/applications/luci-watchcat/luasrc/model/cbi/watchcat/watchcat.lua b/applications/luci-watchcat/luasrc/model/cbi/watchcat/watchcat.lua
deleted file mode 100644
index fd7038c87..000000000
--- a/applications/luci-watchcat/luasrc/model/cbi/watchcat/watchcat.lua
+++ /dev/null
@@ -1,64 +0,0 @@
---[[
-LuCI - Lua Configuration Interface
-
-Copyright 2012 Christian Gagneraud <chris@techworks.ie>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-$Id$
-]]--
-
-m = Map("system",
- translate("Watchcat"),
- translate("Watchcat allows configuring a periodic reboot when the " ..
- "Internet connection has been lost for a certain period of time."
- ))
-
-s = m:section(TypedSection, "watchcat")
-s.anonymous = true
-s.addremove = true
-
-mode = s:option(ListValue, "mode",
- translate("Operating mode"))
-mode.default = "allways"
-mode:value("ping", "Reboot on internet connection lost")
-mode:value("allways", "Periodic reboot")
-
-forcedelay = s:option(Value, "forcedelay",
- translate("Forced reboot delay"),
- translate("When rebooting the system, the watchcat will trigger a soft reboot. " ..
- "Entering a non zero value here will trigger a delayed hard reboot " ..
- "if the soft reboot fails. Enter a number of seconds to enable, " ..
- "use 0 to disable"))
-forcedelay.datatype = "uinteger"
-forcedelay.default = "0"
-
-period = s:option(Value, "period",
- translate("Period"),
- translate("In periodic mode, it defines the reboot period. " ..
- "In internet mode, it defines the longest period of " ..
- "time without internet access before a reboot is engaged." ..
- "Default unit is seconds, you can use the " ..
- "suffix 'm' for minutes, 'h' for hours or 'd' " ..
- "for days"))
-
-pinghost = s:option(Value, "pinghosts",
- translate("Ping host"),
- translate("Host address to ping"))
-pinghost.datatype = "host"
-pinghost.default = "8.8.8.8"
-pinghost:depends({mode="ping"})
-
-pingperiod = s:option(Value, "pingperiod",
- translate("Ping period"),
- translate("How often to check internet connection. " ..
- "Default unit is seconds, you can you use the " ..
- "suffix 'm' for minutes, 'h' for hours or 'd' " ..
- "for days"))
-pingperiod:depends({mode="ping"})
-
-return m
diff --git a/applications/luci-watchcat/root/etc/uci-defaults/luci-watchcat b/applications/luci-watchcat/root/etc/uci-defaults/luci-watchcat
deleted file mode 100644
index 8cdb8c7b9..000000000
--- a/applications/luci-watchcat/root/etc/uci-defaults/luci-watchcat
+++ /dev/null
@@ -1,10 +0,0 @@
-#!/bin/sh
-
-uci -q batch <<-EOF >/dev/null
- add ucitrack system
- set ucitrack.@system[-1].init=watchcat
- commit ucitrack
-EOF
-
-rm -f /tmp/luci-indexcache
-exit 0