summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-voice-diag
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-07-17 20:27:05 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-07-17 20:27:05 +0000
commit820f11932f548182ebb32704e1df83b78e69b19e (patch)
treece56e5183f28520ce6078aa5fd723d8bb3f2b310 /applications/luci-voice-diag
parent768bf67b867df0fde2715308eef482cb677a8566 (diff)
[PATCH] add tools to scan network for any device, or for sip devices, and output device information, thanks cshore
Diffstat (limited to 'applications/luci-voice-diag')
-rw-r--r--applications/luci-voice-diag/Makefile4
-rw-r--r--applications/luci-voice-diag/luasrc/controller/luci_voice/luci_voice_diag.lua25
-rw-r--r--applications/luci-voice-diag/luasrc/view/luci_voice/diag_index.htm18
3 files changed, 47 insertions, 0 deletions
diff --git a/applications/luci-voice-diag/Makefile b/applications/luci-voice-diag/Makefile
new file mode 100644
index 000000000..b764ed43a
--- /dev/null
+++ b/applications/luci-voice-diag/Makefile
@@ -0,0 +1,4 @@
+PO=voice_diag
+
+include ../../build/config.mk
+include ../../build/module.mk
diff --git a/applications/luci-voice-diag/luasrc/controller/luci_voice/luci_voice_diag.lua b/applications/luci-voice-diag/luasrc/controller/luci_voice/luci_voice_diag.lua
new file mode 100644
index 000000000..e0dccb051
--- /dev/null
+++ b/applications/luci-voice-diag/luasrc/controller/luci_voice/luci_voice_diag.lua
@@ -0,0 +1,25 @@
+--[[
+
+Luci Voice Core
+(c) 2009 Daniel Dickinson
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+]]--
+
+
+module("luci.controller.luci_voice.luci_voice_diag", package.seeall)
+
+function index()
+ require("luci.i18n")
+ luci.i18n.loadc("voice_diag")
+
+ local e = entry({"admin", "voice", "diag"}, template("luci_voice/diag_index") , luci.i18n.translate("l_v_d_admindiag"), 90)
+ e.index = true
+ e.i18n = "voice_diag"
+ e.dependent = true
+end
diff --git a/applications/luci-voice-diag/luasrc/view/luci_voice/diag_index.htm b/applications/luci-voice-diag/luasrc/view/luci_voice/diag_index.htm
new file mode 100644
index 000000000..010eaf769
--- /dev/null
+++ b/applications/luci-voice-diag/luasrc/view/luci_voice/diag_index.htm
@@ -0,0 +1,18 @@
+<%#
+LuCI - Lua Configuration Interface
+(c) 2009 Daniel Dickinson
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+
+-%>
+<%+header%>
+<h2><a id="content" name="content"><%:l_v_d_di_voicediag%></a></h2>
+<p><%:l_v_d_di_voicediag1%></p>
+<p><%:l_v_d_di_voicediag2%></p>
+<%+footer%>