summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-voice-core
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-07-17 20:27:05 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-07-17 20:27:05 +0000
commit820f11932f548182ebb32704e1df83b78e69b19e (patch)
treece56e5183f28520ce6078aa5fd723d8bb3f2b310 /applications/luci-voice-core
parent768bf67b867df0fde2715308eef482cb677a8566 (diff)
[PATCH] add tools to scan network for any device, or for sip devices, and output device information, thanks cshore
Diffstat (limited to 'applications/luci-voice-core')
-rw-r--r--applications/luci-voice-core/Makefile4
-rw-r--r--applications/luci-voice-core/luasrc/controller/luci_voice.lua37
-rw-r--r--applications/luci-voice-core/luasrc/view/luci_voice/index.htm24
-rw-r--r--applications/luci-voice-core/luasrc/view/luci_voice/phone_index.htm20
4 files changed, 85 insertions, 0 deletions
diff --git a/applications/luci-voice-core/Makefile b/applications/luci-voice-core/Makefile
new file mode 100644
index 000000000..d57c456d5
--- /dev/null
+++ b/applications/luci-voice-core/Makefile
@@ -0,0 +1,4 @@
+PO=voice_core
+
+include ../../build/config.mk
+include ../../build/module.mk
diff --git a/applications/luci-voice-core/luasrc/controller/luci_voice.lua b/applications/luci-voice-core/luasrc/controller/luci_voice.lua
new file mode 100644
index 000000000..4d8873e9f
--- /dev/null
+++ b/applications/luci-voice-core/luasrc/controller/luci_voice.lua
@@ -0,0 +1,37 @@
+--[[
+
+Luci Voice Core
+(c) 2009 Daniel Dickinson
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+]]--
+
+
+module("luci.controller.luci_voice", package.seeall)
+
+function index()
+ require("luci.i18n")
+ luci.i18n.loadc("voice_core")
+
+ local e = entry({"admin", "voice"}, template("luci_voice/index") , luci.i18n.translate("l_v_adminvoice", "Voice"), 90)
+ e.index = true
+ e.i18n = "voice_core"
+
+ e = entry({"mini", "voice"}, template("luci_voice/index"), luci.i18n.translate("l_v_minivoice", "Voice"), 90)
+ e.index = true
+ e.i18n = "voice_core"
+
+ e = entry({"mini", "voice", "phones"}, template("luci_voice/phone_index"), luci.i18n.translate("l_v_miniphones"), 90)
+ e.index = true
+ e.i18n = "voice_core"
+
+ e = entry({"admin", "voice", "phones"}, template("luci_voice/phone_index"), luci.i18n.translate("l_v_adminphones"), 90)
+ e.index = true
+ e.i18n = "voice_core"
+
+end
diff --git a/applications/luci-voice-core/luasrc/view/luci_voice/index.htm b/applications/luci-voice-core/luasrc/view/luci_voice/index.htm
new file mode 100644
index 000000000..73d2ce446
--- /dev/null
+++ b/applications/luci-voice-core/luasrc/view/luci_voice/index.htm
@@ -0,0 +1,24 @@
+<%#
+LuCI - Lua Configuration Interface
+(c) 2009 Daniel Dickinson
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+
+-%>
+<%+header%>
+<h2><a id="content" name="content">Voice</a></h2>
+<p>Here you can control OpenWRT voice-related settings and see
+ voice-related information from OpenWRT</p>
+<p>In particular Asterisk configuration and information is displayed
+ here, as well as diagnostics that specifically apply to voice but are
+ not general networking diagnostics (e.g. includes SIP device scans, but not
+ ping tests). Includes PSTN phones as well as VoIP and possibly
+ non-telephony related options.
+</p>
+<%+footer%>
diff --git a/applications/luci-voice-core/luasrc/view/luci_voice/phone_index.htm b/applications/luci-voice-core/luasrc/view/luci_voice/phone_index.htm
new file mode 100644
index 000000000..89b866114
--- /dev/null
+++ b/applications/luci-voice-core/luasrc/view/luci_voice/phone_index.htm
@@ -0,0 +1,20 @@
+<%#
+LuCI - Lua Configuration Interface
+(c) 2009 Daniel Dickinson
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+
+-%>
+<%+header%>
+<h2><a id="content" name="content">Phones</a></h2>
+<p>Here you can control phone configuration and information in OpenWRT</p>
+<p>You can control the setup of phone clients and servers and see
+ information such as diagnostics related to phone devices from this menu.
+</p>
+<%+footer%>