summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-uvc_streamer
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-03-07 18:42:12 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-03-07 18:42:12 +0000
commit1973a023292d88fb87b3c9aa9d9f6495599f0be6 (patch)
tree64925bcdd0ea73526857b7d3a19cf54e84fa249d /applications/luci-uvc_streamer
parent66fc0c4692401a5fc1e3633b58408fb5e7a20f63 (diff)
trunk: drop uvc_stremaer support, package was removed upstream
Diffstat (limited to 'applications/luci-uvc_streamer')
-rw-r--r--applications/luci-uvc_streamer/Makefile4
-rwxr-xr-xapplications/luci-uvc_streamer/ipkg/postinst5
-rw-r--r--applications/luci-uvc_streamer/luasrc/controller/uvc_streamer.lua28
-rw-r--r--applications/luci-uvc_streamer/luasrc/model/cbi/uvc_streamer.lua47
-rw-r--r--applications/luci-uvc_streamer/root/etc/uci-defaults/luci-uvc_streamer7
-rw-r--r--applications/luci-uvc_streamer/root/lib/uci/schema/default/uvc-streamer41
6 files changed, 0 insertions, 132 deletions
diff --git a/applications/luci-uvc_streamer/Makefile b/applications/luci-uvc_streamer/Makefile
deleted file mode 100644
index eb78c9382..000000000
--- a/applications/luci-uvc_streamer/Makefile
+++ /dev/null
@@ -1,4 +0,0 @@
-PO = uvc_streamer
-
-include ../../build/config.mk
-include ../../build/module.mk
diff --git a/applications/luci-uvc_streamer/ipkg/postinst b/applications/luci-uvc_streamer/ipkg/postinst
deleted file mode 100755
index d0cf7fec6..000000000
--- a/applications/luci-uvc_streamer/ipkg/postinst
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-[ -n "${IPKG_INSTROOT}" ] || {
- ( . /etc/uci-defaults/luci-uvc_streamer ) && rm -f /etc/uci-defaults/luci-uvc_streamer
- /etc/init.d/uvc-streamer enabled || /etc/init.d/uvc-streamer enable
-}
diff --git a/applications/luci-uvc_streamer/luasrc/controller/uvc_streamer.lua b/applications/luci-uvc_streamer/luasrc/controller/uvc_streamer.lua
deleted file mode 100644
index 7b995c26b..000000000
--- a/applications/luci-uvc_streamer/luasrc/controller/uvc_streamer.lua
+++ /dev/null
@@ -1,28 +0,0 @@
---[[
-
-LuCI UVC Streamer
-(c) 2008 Yanira <forum-2008@email.de>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-$Id$
-
-]]--
-
-module("luci.controller.uvc_streamer", package.seeall)
-
-function index()
- require("luci.i18n")
- luci.i18n.loadc("uvc_streamer")
- if not nixio.fs.access("/etc/config/uvc-streamer") then
- return
- end
-
- local page = entry({"admin", "services", "uvc_streamer"}, cbi("uvc_streamer"), luci.i18n.translate("Webcam streaming"), 60)
- page.i18n = "uvc_streamer"
- page.dependent = true
-end
diff --git a/applications/luci-uvc_streamer/luasrc/model/cbi/uvc_streamer.lua b/applications/luci-uvc_streamer/luasrc/model/cbi/uvc_streamer.lua
deleted file mode 100644
index 469ea6f00..000000000
--- a/applications/luci-uvc_streamer/luasrc/model/cbi/uvc_streamer.lua
+++ /dev/null
@@ -1,47 +0,0 @@
---[[
-
-LuCI UVC Streamer
-(c) 2008 Yanira <forum-2008@email.de>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-$Id$
-
-]]--
-
--- find current lan address and port of first uvc_streamer config section
-local uci = luci.model.uci.cursor_state()
-local addr = uci:get("network", "lan", "ipaddr")
-local port
-
-uci:foreach( "uvc-streamer", "uvc-streamer",
- function(section) port = port or tonumber(section.port) end )
-
-addr = addr or "192.168.1.1"
-port = port or 8080
-
-m = Map("uvc-streamer", translate("Webcam streaming"),
- translatef("uvc_streamer_desc", nil, addr, port, addr, port))
-
-s = m:section(TypedSection, "uvc-streamer", translate("Settings"))
-s.addremove = false
-s.anonymous = true
-
-s:option(Flag, "enabled", translate("Enable"))
-
-s:option(Value, "device", translate("Device")).rmempty = true
-
-nm = s:option(Value, "resolution", translate("Resolution"))
-nm:value("640x480")
-nm:value("320x240")
-nm:value("160x120")
-
-s:option(Value, "framespersecond", translate("Frames per second")).rmempty = true
-
-s:option(Value, "port", translate("Port")).rmempty = true
-
-return m
diff --git a/applications/luci-uvc_streamer/root/etc/uci-defaults/luci-uvc_streamer b/applications/luci-uvc_streamer/root/etc/uci-defaults/luci-uvc_streamer
deleted file mode 100644
index 42372f051..000000000
--- a/applications/luci-uvc_streamer/root/etc/uci-defaults/luci-uvc_streamer
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-uci batch <<-EOF
- add ucitrack uvc-streamer
- set ucitrack.@uvc-streamer[-1].init=uvc-streamer
- commit ucitrack
-EOF
diff --git a/applications/luci-uvc_streamer/root/lib/uci/schema/default/uvc-streamer b/applications/luci-uvc_streamer/root/lib/uci/schema/default/uvc-streamer
deleted file mode 100644
index 9ea255c31..000000000
--- a/applications/luci-uvc_streamer/root/lib/uci/schema/default/uvc-streamer
+++ /dev/null
@@ -1,41 +0,0 @@
-#package uvc-streamer
-
-config package
- option title 'UVC-Streamer webcam streaming configuration'
-
-config section
- option name 'uvc-streamer'
- option package 'uvc-streamer'
- option title 'Settings'
- option unique true
- option required true
-
-config variable
- option name 'enabled'
- option section 'uvc-streamer.uvc-streamer'
- option title 'Enable'
- option required true
- option datatype boolean
-
-config variable
- option name 'device'
- option section 'uvc-streamer.uvc-streamer'
- option title 'Device'
-
-config variable
- option name 'resolution'
- option section 'uvc-streamer.uvc-streamer'
- option title 'Resolution'
- option required true
-
-config variable
- option name 'framespersecond'
- option section 'uvc-streamer.uvc-streamer'
- option title 'Frames per second'
- option datatype uint
-
-config variable
- option name 'port'
- option section 'uvc-streamer.uvc-streamer'
- option title 'Port'
- option datatype port